summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-01-15 11:25:16 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2024-01-16 17:49:28 +0100
commit4bc9568b9d265d301c350f372d8d594ea42b59d3 (patch)
tree8b73f7bac964cde0c0332e3140fd25f817b153ad /recipes-bsp
parent0a9b7135ab19a7a8abcd0ba68a6bba2f83cd7530 (diff)
downloadmeta-freescale-4bc9568b9d265d301c350f372d8d594ea42b59d3.tar.gz
isp-imx: fix build against updated tinyxml2
Latest master meta-oe updated tinyxml2 to version 10.0.0. isp-imx packages a prebuilt library dynamically linked against tinyxml2.so.9 which is no longer provided, thus: | ERROR: isp-imx-4.2.2.22.0-r0 do_package_qa: QA Issue: /usr/lib/libcam_device.so contained in package isp-imx requires libtinyxml2.so.9()(64bit), but no providers found in RDEPENDS:isp-imx? [file-rdeps] Fix the build by updating the dynamic section to require tinyxml2.so.10. Note that I don't have a system to runtime test if that still works. The tinyxml API doesn't look like it changed from 9 to 10. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.22.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.22.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.22.0.bb
index 39d7d770..7d0406fd 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.22.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.22.0.bb
@@ -3,7 +3,7 @@
3DESCRIPTION = "i.MX Verisilicon Software ISP" 3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=63a38e9f392d8813d6f1f4d0d6fbe657" 5LIC_FILES_CHKSUM = "file://COPYING;md5=63a38e9f392d8813d6f1f4d0d6fbe657"
6DEPENDS = "boost libdrm virtual/libg2d libtinyxml2" 6DEPENDS = "boost libdrm virtual/libg2d libtinyxml2 patchelf-native"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ 9 ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
@@ -47,6 +47,12 @@ EXTRA_OECMAKE += " \
47 -Wno-dev \ 47 -Wno-dev \
48" 48"
49 49
50do_configure:prepend () {
51 # FIXME: Should be rebuild.
52 patchelf --replace-needed libtinyxml2.so.9 libtinyxml2.so.10 ${S}/units/cam_device/proprietories/lib/libcam_device.so
53 patchelf --replace-needed libtinyxml2.so.9 libtinyxml2.so.10 ${S}/mediacontrol/lib/arm-64/fpga/libcam_device.so
54}
55
50do_install() { 56do_install() {
51 install -d ${D}/${libdir} 57 install -d ${D}/${libdir}
52 install -d ${D}/${includedir} 58 install -d ${D}/${includedir}