summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-01-11 03:14:06 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-01-14 16:23:38 -0200
commit0cc047c53ff5155e23a8901881415d5a7ac37054 (patch)
tree5369df5243f77b2d1b3bc79e47395d66e9884562 /recipes-bsp
parent4bee74fcaa6538c7b7192a73c91dc086011e0c85 (diff)
downloadmeta-freescale-0cc047c53ff5155e23a8901881415d5a7ac37054.tar.gz
ppa: remove ppa
*This pkg will not be supported anymore Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ppa/ppa-optee_git.bb18
-rw-r--r--recipes-bsp/ppa/ppa.inc54
-rw-r--r--recipes-bsp/ppa/ppa_git.bb20
3 files changed, 0 insertions, 92 deletions
diff --git a/recipes-bsp/ppa/ppa-optee_git.bb b/recipes-bsp/ppa/ppa-optee_git.bb
deleted file mode 100644
index 41896baf..00000000
--- a/recipes-bsp/ppa/ppa-optee_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1require ppa.inc
2
3DEPENDS += "optee-os-qoriq"
4
5PPA_PATH_ls1046a = "ls1046"
6PPA_PATH_ls1043a = "ls1043"
7PPA_PATH_ls1012a = "ls1012"
8PPA_PATH_ls2088a = "ls2088"
9
10do_compile() {
11 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
12 cp ${RECIPE_SYSROOT}/lib/firmware/tee_${MACHINE}.bin ${S}/ppa/soc-${PPA_PATH}/tee.bin
13 cd ${S}/ppa
14 ./build rdb-fit spd=on ${PPA_PATH}
15 cd ${S}
16}
17
18COMPATIBLE_MACHINE = "(ls1043a|ls1046a|ls1012a|ls2088a)"
diff --git a/recipes-bsp/ppa/ppa.inc b/recipes-bsp/ppa/ppa.inc
deleted file mode 100644
index 8125375c..00000000
--- a/recipes-bsp/ppa/ppa.inc
+++ /dev/null
@@ -1,54 +0,0 @@
1SUMMARY = "Primary Protected Application"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://license.txt;md5=2ecf925c01a48f61c88f78c30fe2ee3b"
4
5DEPENDS += "u-boot-mkimage-native dtc-native"
6
7inherit deploy
8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ppa-generic;nobranch=1 \
10"
11SRCREV = "90e13c9e148972f75f5f2e7f7a904dabf1586049"
12
13S = "${WORKDIR}/git"
14
15python () {
16 ml = d.getVar("MULTILIB_VARIANTS", True)
17 arch = d.getVar("OVERRIDES", True)
18 if "fsl-lsch2-32b:" in arch:
19 if not "lib64" in ml:
20 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
21 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux'
22 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS')
23 workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib)
24 d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc')
25 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib)
26 d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot')
27 d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-')
28}
29
30WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
31EXTRA_OEMAKE = 'CC64="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" LD64="${WRAP_TARGET_PREFIX}ld ${TOOLCHAIN_OPTIONS}" OBJ64="${WRAP_TARGET_PREFIX}objcopy"'
32
33PPA_NAME = "${PN}-${MACHINE}-${DATETIME}"
34PPA_NAME[vardepsexclude] = "DATETIME"
35
36do_install() {
37 install -d ${D}/boot/
38 install ${S}/ppa/soc-${PPA_PATH}/build/obj/ppa.itb ${D}/boot/${PPA_NAME}.itb
39 ln -sfT ${PPA_NAME}.itb ${D}/boot/${PN}.itb
40}
41
42do_deploy(){
43 install -d ${DEPLOYDIR}
44 install ${S}/ppa/soc-${PPA_PATH}/build/obj/ppa.itb ${DEPLOYDIR}/${PPA_NAME}.itb
45 ln -sfT ${PPA_NAME}.itb ${DEPLOYDIR}/${PN}.itb
46}
47addtask deploy before do_build after do_install
48
49PACKAGES += "${PN}-image"
50FILES_${PN}-image += "/boot"
51
52CLEANBROKEN = "1"
53PARALLEL_MAKE = ""
54PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/ppa/ppa_git.bb b/recipes-bsp/ppa/ppa_git.bb
deleted file mode 100644
index 5413d7d4..00000000
--- a/recipes-bsp/ppa/ppa_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1require ppa.inc
2
3PPA_PATH_ls1012a = "ls1012"
4PPA_PATH_ls1043a = "ls1043"
5PPA_PATH_ls1046a = "ls1046"
6PPA_PATH_ls2088a = "ls2088"
7PPA_PATH_ls1088a = "ls1088"
8
9do_compile () {
10 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
11 cd ${S}/ppa
12 if [ ${MACHINE} = ls1012afrdm ];then
13 ./build frdm-fit ${PPA_PATH}
14 else
15 ./build rdb-fit ${PPA_PATH}
16 fi
17 cd ${S}
18}
19
20COMPATIBLE_MACHINE = "(ls1043a|ls1046a|ls2088a|ls1012a|ls1088a)"