summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-10-06 17:34:40 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-06 17:40:44 -0300
commit5828e33990aaecb952dde7e664107da8cc25b2e7 (patch)
tree396a0e3c0e5742c687c6e7aef4247900c0c628b0 /recipes-bsp/u-boot
parent909463cb49a0ea287921bc6189dcd941a652a778 (diff)
downloadmeta-freescale-5828e33990aaecb952dde7e664107da8cc25b2e7.tar.gz
u-boot-fslc: Add specific bits for u-boot-fslc only
- u-boot-msxboot doesn't use recipes-bsp/u-boot/u-boot.inc, so require this file only in recipes that use it. - Compatible machine and package arch are needed only for u-boot-fslc, once u-boot-fw-utils has cross class and u-boot-mxsboot has native class. - Add description in u-boot-fslc recipe - Drop unused depends for mxs. We don't need to use elftosb, mkimage can generate an BootStream for i.MX23 and i.MX28. See u-boot-fslc commit 6654f33c9b520bd4073c7f82a13044e79bc1489. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc12
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2017.09.bb11
2 files changed, 11 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
index f2b4e83a..7bfe3316 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
@@ -1,20 +1,10 @@
1# Copyright (C) 2012-2017 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2017 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4require recipes-bsp/u-boot/u-boot.inc
5
6inherit fsl-u-boot-localversion 4inherit fsl-u-boot-localversion
7 5
8DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
9order to provide support for some backported features and fixes, or because it \
10was submitted for revision and it takes some time to become part of a stable \
11version, or because it is not applicable for upstreaming."
12LICENSE = "GPLv2+" 6LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" 7LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
14COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"
15
16DEPENDS_append = " dtc-native"
17DEPENDS_mxs += "elftosb-native openssl-native"
18 8
19SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 9SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
20 10
@@ -24,5 +14,3 @@ SRCBRANCH = "2017.09+fslc"
24PV = "v2017.09+git${SRCPV}" 14PV = "v2017.09+git${SRCPV}"
25 15
26S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
27
28PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
index 3aff2fa7..5659e16c 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
@@ -1,5 +1,13 @@
1require recipes-bsp/u-boot/u-boot.inc
1require u-boot-fslc-common_${PV}.inc 2require u-boot-fslc-common_${PV}.inc
2 3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9DEPENDS_append = " dtc-native"
10
3PROVIDES += "u-boot" 11PROVIDES += "u-boot"
4 12
5# FIXME: Allow linking of 'tools' binaries with native libraries 13# FIXME: Allow linking of 'tools' binaries with native libraries
@@ -8,3 +16,6 @@ PROVIDES += "u-boot"
8EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ 16EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
9 HOSTLDFLAGS="${BUILD_LDFLAGS}" \ 17 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
10 HOSTSTRIP=true' 18 HOSTSTRIP=true'
19
20PACKAGE_ARCH = "${MACHINE_ARCH}"
21COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"