summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-05-07 19:50:51 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-08 10:11:36 -0300
commitfa5c18a91cfd0fa3478fb6ead2898ac9e1942bd9 (patch)
tree3a0d4b66d595c0820e01108007b2de95a27c0181 /recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
parent6ef0f40c2542655872e76c8cdd5cbe3c37c4c8db (diff)
downloadmeta-freescale-fa5c18a91cfd0fa3478fb6ead2898ac9e1942bd9.tar.gz
u-boot-qoriq: fix pylibfdt build with Python3
Backport patches to fix build failure on powerpc machines: | /bin/sh: 1: python2: not found | make[4]: *** [scripts/dtc/pylibfdt/_libfdt.so] Error 127 | make[3]: *** [scripts/dtc/pylibfdt] Error 2 Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb b/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
index a47b91a3..8d79e17a 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
@@ -46,6 +46,7 @@ ENDIANNESS_LD = "${@bb.utils.contains("LE_UBOOT_FOR_ARMBE_TARGET", "1", "-EL", "
46WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 46WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
47EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${ENDIANNESS_GCC}" LD="${WRAP_TARGET_PREFIX}ld ${ENDIANNESS_LD}" V=1' 47EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${ENDIANNESS_GCC}" LD="${WRAP_TARGET_PREFIX}ld ${ENDIANNESS_LD}" V=1'
48EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"' 48EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
49EXTRA_OEMAKE += 'STAGING_INCDIR=${STAGING_INCDIR_NATIVE} STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE}'
49 50
50do_compile_append_qoriq() { 51do_compile_append_qoriq() {
51 unset i j k 52 unset i j k