summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-15 09:25:26 +0530
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 08:38:13 -0300
commitbd61523a08419322b5bb71bd84b5f719ec1eab71 (patch)
tree2b24297a00cdd4128ab18189c06bcee7bbc7cb11 /recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
parent1ecd36e2c99c311dca574cc901b24d32762e5de9 (diff)
downloadmeta-freescale-bd61523a08419322b5bb71bd84b5f719ec1eab71.tar.gz
u-boot-qoriq: update to LSDK-20.12 release (2020.04)
Key changes: * Upgrade to 2020.04 * Support of LX2162A QDS * GPIO on LX2160A * SDHC: HS200 and HS400 on LX2162A * Watchdog: SBSA on LX2160A Backported patches are removed. Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb107
1 files changed, 0 insertions, 107 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb b/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
deleted file mode 100644
index 571fadb7..00000000
--- a/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb
+++ /dev/null
@@ -1,107 +0,0 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards"
4PROVIDES += "u-boot"
5
6inherit fsl-u-boot-localversion
7
8LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
9LIC_FILES_CHKSUM = " \
10 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
12 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
13 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
14 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
15"
16
17SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/u-boot;nobranch=1 \
18 file://0001-patman-Drop-binary-parameter.patch \
19 file://0001-patman-Update-command.Run-to-handle-failure-better.patch \
20 file://0001-patman-Adjust-command-to-return-strings-instead-of-b.patch \
21 file://0001-pylibfdt-Convert-to-Python-3.patch \
22 file://0001-binman-Convert-a-few-tests-to-Python-3.patch \
23 file://0001-binman-Move-to-use-Python-3.patch \
24 file://0001-buildman-Convert-to-Python-3.patch \
25 file://0001-Remove-redundant-YYLOC-global-declaration.patch \
26"
27SRCREV= "1e55b2f9e7f56b76569089b9e950f49c1579580e"
28
29S = "${WORKDIR}/git"
30B = "${WORKDIR}/build"
31PV_append = "+fslgit"
32LOCALVERSION = "+fsl"
33
34INHIBIT_DEFAULT_DEPS = "1"
35DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc bison-native bc-native swig-native python3-native"
36DEPENDS_append_qoriq-arm64 = " dtc-native"
37DEPENDS_append_qoriq-arm = " dtc-native"
38DEPENDS_append_qoriq-ppc = " boot-format-native"
39
40python () {
41 if d.getVar("TCMODE") == "external-fsl":
42 return
43
44 ml = d.getVar("MULTILIB_VARIANTS")
45 arch = d.getVar("OVERRIDES")
46
47 if "e5500-64b:" in arch or "e6500-64b:" in arch:
48 if not "lib32" in ml:
49 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
50 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib32-linux'
51 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS')
52 workdir = d.getVar('WORKDIR')
53 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc')
54 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/powerpc' + sys_multilib)
55 d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib32-recipe-sysroot')
56 d.setVar("WRAP_TARGET_PREFIX", 'powerpc' + sys_multilib + '-')
57 elif "fsl-lsch2-32b:" in arch:
58 if not "lib64" in ml:
59 raise bb.parse.SkipRecipe("Building the u-boot for this arch requires multilib to be enabled")
60 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux'
61 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS')
62 workdir = d.getVar('WORKDIR')
63 d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc')
64 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib)
65 d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot')
66 d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-')
67}
68
69LE_UBOOT_FOR_ARMBE_TARGET ?= "0"
70ENDIANNESS_GCC = "${@bb.utils.contains("LE_UBOOT_FOR_ARMBE_TARGET", "1", "-mlittle-endian", "", d)}"
71ENDIANNESS_LD = "${@bb.utils.contains("LE_UBOOT_FOR_ARMBE_TARGET", "1", "-EL", "", d)}"
72
73WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
74EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${ENDIANNESS_GCC}" LD="${WRAP_TARGET_PREFIX}ld ${ENDIANNESS_LD}" V=1'
75EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
76EXTRA_OEMAKE += 'STAGING_INCDIR=${STAGING_INCDIR_NATIVE} STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE}'
77
78do_compile_append_qoriq() {
79 unset i j k
80 for config in ${UBOOT_MACHINE}; do
81 i=`expr $i + 1`;
82 for type in ${UBOOT_CONFIG}; do
83 j=`expr $j + 1`;
84 for binary in ${UBOOT_BINARIES}; do
85 k=`expr $k + 1`
86 if [ $j -eq $i ] && [ $k -eq $i ]; then
87 if [ -n "${BOOTFORMAT_CONFIG}" ] && echo "${type}" |grep -q spi;then
88 # regenerate spi binary if BOOTFORMAT_CONFIG is set
89 boot_format ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \
90 ${config}/u-boot-${type}.${UBOOT_SUFFIX} -spi ${config}/u-boot.format.bin
91 cp ${config}/u-boot.format.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX}
92 elif [ "qspi" = "${type}" ];then
93 cp ${config}/${binary} ${config}/u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX}
94 fi
95 fi
96 done
97 unset k
98 done
99 unset j
100 done
101 unset i
102}
103
104
105PACKAGES += "${PN}-images"
106FILES_${PN}-images += "/boot"
107COMPATIBLE_MACHINE = "(qoriq)"