summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-23 10:16:14 -0300
committerGitHub <noreply@github.com>2022-02-23 10:16:14 -0300
commite1687f81e0cc4a61c5d853c9b9df561ebc5ef88a (patch)
treed8b2e84e2e00f92a43fc9ca5e1d361b6091cc1cc /recipes-bsp/u-boot/u-boot-imx_2021.04.bb
parenta021abc00aaddfffaffcddacd7334f704b73ca6c (diff)
parentb937d5b9e3ddf8025a72a0c0b6083e5482e9cf4d (diff)
downloadmeta-freescale-e1687f81e0cc4a61c5d853c9b9df561ebc5ef88a.tar.gz
Merge pull request #980 from Freescale/topic/generalize-soc-overrides
Generalize overrides subsystem for NXP and Mainline support
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2021.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index 96552eef..21883af8 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -10,13 +10,13 @@ PROVIDES += "u-boot"
10inherit uuu_bootloader_tag 10inherit uuu_bootloader_tag
11 11
12UUU_BOOTLOADER = "" 12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6 = "${UBOOT_BINARY}" 13UUU_BOOTLOADER:mx6-nxp-bsp = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7 = "${UBOOT_BINARY}" 14UUU_BOOTLOADER:mx7-nxp-bsp = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = "" 15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-tagged.${UBOOT_SUFFIX}" 16UUU_BOOTLOADER_TAGGED:mx6-nxp-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-tagged.${UBOOT_SUFFIX}" 17UUU_BOOTLOADER_TAGGED:mx7-nxp-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
18 18
19do_deploy:append:mx8m() { 19do_deploy:append:mx8m-nxp-bsp() {
20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
21 if [ -n "${UBOOT_CONFIG}" ] 21 if [ -n "${UBOOT_CONFIG}" ]
22 then 22 then
@@ -38,4 +38,4 @@ do_deploy:append:mx8m() {
38} 38}
39 39
40PACKAGE_ARCH = "${MACHINE_ARCH}" 40PACKAGE_ARCH = "${MACHINE_ARCH}"
41COMPATIBLE_MACHINE = "(mx6|mx7|mx8|use-mainline-bsp)" 41COMPATIBLE_MACHINE = "(mx6-generic-bsp|mx7-generic-bsp|mx8-generic-bsp)"