summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2024.04.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-04-16 17:04:06 -0300
committerGitHub <noreply@github.com>2024-04-16 17:04:06 -0300
commit5814ce5822d4ea511311c9732b18b0aad87f782e (patch)
tree8a44e298b29898f346dd25f89d6f61dca32e8d93 /recipes-bsp/u-boot/u-boot-fslc_2024.04.bb
parent9f9193769926c4233982d7680d8aaeb3fe085c43 (diff)
parent692f8d9c25ec69abbbfed1e98c478cd2f77f9e5b (diff)
downloadmeta-freescale-5814ce5822d4ea511311c9732b18b0aad87f782e.tar.gz
Merge pull request #1787 from rafluan/topic/u-boot-updates
u-boot-fslc: Bump from v2024.01 to v2024.04
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2024.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2024.04.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2024.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2024.04.bb
new file mode 100644
index 00000000..eba8876a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2024.04.bb
@@ -0,0 +1,25 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native"
12
13PROVIDES += "u-boot u-boot-mfgtool"
14
15B = "${WORKDIR}/build"
16
17# FIXME: Allow linking of 'tools' binaries with native libraries
18# used for generating the boot logo and other tools used
19# during the build process.
20EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
21 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
22 HOSTSTRIP=true'
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25COMPATIBLE_MACHINE = "(imx-generic-bsp)"