summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-11-27 14:24:23 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2018-11-27 14:24:23 -0200
commit15adae4343c8242ce150899a30fdc82b1f350e10 (patch)
treeb0a6660ef318dea54510beab6f1bf61082328400 /recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
parent0daa6c78258da381fa15e98be69a8ddef5f783a5 (diff)
downloadmeta-freescale-15adae4343c8242ce150899a30fdc82b1f350e10.tar.gz
u-boot-fslc: Upgrade to 2018.11-based fork
This upgrade our fork to the current stable release. It got most of our patches merged and now it has a very small set which are basically Yocto Project specific stuff. Still applied patches are: 1f39b911b7 mx25pdk: Change root to use a single partition layout a0f8bec9d3 mx6sabre_common: Dynamically change the video output 7847536319 mx6sabresd: Enable video interfaces in bootargs 994d8e0733 mx6sabresd: Use LDO dtb file until LDO bypass support is added c6c87fb39b mx6slevk: Use LDO dtb file until LDO bypass support is added Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
deleted file mode 100644
index e582ea8c..00000000
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1require u-boot-fslc-common_${PV}.inc
2
3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader"
5
6DEPENDS = "bison-native dtc openssl"
7
8PROVIDES = "u-boot-mxsboot"
9
10EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
12EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
13
14do_compile () {
15 oe_runmake sandbox_defconfig
16
17 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
18 # generating it requires bin2header tool, which for target build
19 # is built with target tools and thus cannot be executed on host.
20 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
21
22 oe_runmake cross_tools NO_SDL=1
23}
24
25do_install () {
26 install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
27 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
28}
29
30BBCLASSEXTEND = "native nativesdk"