summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/libimxdmabuffer
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2020-10-18 13:48:29 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-10-18 13:29:52 -0300
commite026e300420195334fd7e19676f686434983c9f2 (patch)
treeaa3fdf9511792664edcb28cdc22692f8b8fc63d5 /recipes-bsp/libimxdmabuffer
parentaa3189ea5c91eb8c0947474abaf983bcdecc017a (diff)
downloadmeta-freescale-e026e300420195334fd7e19676f686434983c9f2.tar.gz
libimxdmabuffer: Fix allocator packageconfigs for mx8qm and mx8qxp SoCs
The i.MX8 QuadMax and QuadXPlus SoCs can use the ION allocator. Also, if there is a DPU, then G2D will be emulated via the DPU. However, the emulation's allocation functions are broken, so disable the G2D allocator then. Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-bsp/libimxdmabuffer')
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
index 9b918f2c..726b1e16 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
@@ -22,11 +22,19 @@ EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \
22 --libdir=${libdir} \ 22 --libdir=${libdir} \
23 ${PACKAGECONFIG_CONFARGS}" 23 ${PACKAGECONFIG_CONFARGS}"
24 24
25# If imxdpu is in use, the DPU is also used for implementing
26# libg2d. However, that implementation's g2d_alloc() function
27# is broken, so we cannot use it.
28LIBG2D_PACKAGECONFIG = "g2d"
29LIBG2D_PACKAGECONFIG_imxdpu = ""
30
25PACKAGECONFIG ?= " " 31PACKAGECONFIG ?= " "
26PACKAGECONFIG_append_imxgpu2d = " g2d" 32PACKAGECONFIG_append_imxgpu2d = " ${LIBG2D_PACKAGECONFIG}"
27PACKAGECONFIG_append_imxipu = " ipu" 33PACKAGECONFIG_append_imxipu = " ipu"
28PACKAGECONFIG_append_imxpxp = " pxp" 34PACKAGECONFIG_append_imxpxp = " pxp"
29PACKAGECONFIG_append_mx8m = " dwl ion" 35PACKAGECONFIG_append_mx8m = " ion dwl"
36PACKAGECONFIG_append_mx8qm = " ion"
37PACKAGECONFIG_append_mx8qxp = " ion"
30 38
31HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2" 39HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2"
32 40