summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/inphi
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-01-11 03:14:04 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-01-14 16:23:38 -0200
commit4bee74fcaa6538c7b7192a73c91dc086011e0c85 (patch)
tree4551a32e31aab33d8f7017eb3af3bdc80219a048 /recipes-bsp/inphi
parent4babcb9d184254805df479695f8bec1e33b447c2 (diff)
downloadmeta-freescale-4bee74fcaa6538c7b7192a73c91dc086011e0c85.tar.gz
inphi: add recipes
*include the following changes: f22e9ff - in112525: Add Inphi 112525 10G Phy firmware Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp/inphi')
-rw-r--r--recipes-bsp/inphi/inphi_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/inphi/inphi_git.bb b/recipes-bsp/inphi/inphi_git.bb
new file mode 100644
index 00000000..c0c8a776
--- /dev/null
+++ b/recipes-bsp/inphi/inphi_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Firmwares and Standalone Applications"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
4
5inherit deploy fsl-eula-unpack
6
7SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;fsl-eula=true;nobranch=1"
8SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695"
9
10S = "${WORKDIR}/git"
11
12do_install () {
13 install -d ${D}/boot
14 cp -fr ${S}/in112525-phy-ucode.txt ${D}/boot
15}
16
17do_deploy () {
18 install -d ${DEPLOYDIR}/inphi
19 cp -fr ${S}/in112525-phy-ucode.txt ${DEPLOYDIR}/inphi
20}
21addtask deploy before do_build after do_install
22
23PACKAGES += "${PN}-image"
24FILES_${PN}-image += "/boot"
25
26COMPATIBLE_MACHINE = "(qoriq-arm64)"
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28