summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-08-17 12:02:50 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-08-17 12:02:50 -0500
commitcf30c22594126252feeff2bf830d58973b860840 (patch)
tree944c5294c54ce37f2e37b39874614d4ceb66ba21 /recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb
parente89cd876bf942cdaa2e3ad5965e0f0f1fb909a83 (diff)
downloadmeta-freescale-cf30c22594126252feeff2bf830d58973b860840.tar.gz
imx-vpu-hantro: Upgrade 1.26.0 -> 1.26.0
Fixes: 574ccc1 M865SW-952-3: [VPU/V4L2] decoder H264: report drop frames in ctrlsw c312783 M865SW-952-2: [VPU/V4L2] decoder H264: report drop frames in ctrlsw 7c49f12 M865SW-952: [VPU/V4L2] decoder H264: report drop frames in ctrlsw 43e4b11 M865SW-957: [VPU/V4L2] no time stamp reported for vp8 format 2ddd9fe LF-5631 [VPU/H1]: release encoder if try to start encode fail c3274bd M865SW-932 [VPU/H1]: export API to set chromaQpIndexOffset ccfe18a MA-20111 android12: deprecate DMA_BUF_IOCTL_PHYS 3f53902 M865SW-917-6 [VPU/G1] RV: notify client resolution change correctly 60eae86 M865SW-917-5 [VPU/G1] VP8: notify client resolution change correctly 40c4a0a M865SW-917-4 [VPU/G1] AVS: notify client resolution change correctly 4cee63d M865SW-917-3 [VPU/G1] VC1: notify client resolution change correctly 8266291 M865SW-917-2 [VPU/G1] MPEG4: notify client resolution change correctly 10d0dab M865SW-917-1 [VPU/G1] MPEG2: notify client resolution change correctly f6ee4e3 M865SW-915 [VPU/G1] H264: return H264DEC_PIC_CONSUMED if drop frame due to openB_flag f84e808 M865SW-888[VPU/G1] vp9: width align to 8 for DEC_OUT_FRM_RASTER_SCAN Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb
new file mode 100644
index 00000000..ac30b60f
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.26.0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "8d06cdacd7700e9e4c32644bf9804cdd"
11SRC_URI[sha256sum] = "0cf9193923e110d2d9e6576e2c632f1675f0751b4c3de9ef54f32813f442540a"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
18PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
19PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES:${PN} += "/unit_tests"
32
33RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36COMPATIBLE_MACHINE = "(mx8mq-nxp-bsp|mx8mm-nxp-bsp|mx8mp-nxp-bsp)"