summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-10-19 19:00:52 +0000
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2021-10-25 15:21:08 +0000
commit60bfa2b5cf9eac026f873300260893e5be718311 (patch)
tree6875b72f8d8670bb69d84739724800698406bde1 /recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
parent8f5041615e3cc00903b36b4fc06239d7ac4bbce1 (diff)
downloadmeta-freescale-60bfa2b5cf9eac026f873300260893e5be718311.tar.gz
imx-vpu-hantro[-vc]: upgrade to 5.10.52-2.1.0
Hantro VPU libraries are upgraded to following versions in the NXP release 5.10.52-2.1.0: - imx-vpu-hantro: 1.23.0 - imx-vpu-hantro-daemon: 1.1.0 - imx-vpu-hantro-vc: 1.5.0 Drop patch from imx-vpu-hantro-daemon package build as it has been applied upstream and is present in the updated version. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> (cherry picked from commit e723b4c36c366ab83307b53c172e331ba0dc4be1)
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
new file mode 100644
index 00000000..427dbf92
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "3f8d4bb593d851d0523d0146131946ae"
11SRC_URI[sha256sum] = "a312a0b6d32ed16527e5bfcff362b231069428362ad5710f816bca019f70c6a2"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM:mx8mm = "IMX8MM"
18PLATFORM:mx8mq = "IMX8MQ"
19PLATFORM:mx8mp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES:${PN} += "/unit_tests"
32
33RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
34
35COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"