summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2019-05-10 15:38:41 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-05-17 07:50:56 -0300
commitfc36e6877ad43b97bf009b425d4ffef10f737dcd (patch)
tree20c5dad451d9177d382eb8aef3f8e5a91fd77164 /recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
parent01f28eb1c17d5390bcbcf3e6d7266f6253974256 (diff)
downloadmeta-freescale-fc36e6877ad43b97bf009b425d4ffef10f737dcd.tar.gz
imx-vpu-hantro: Upgrade version from 1.8.0 to 1.11.0
-[hantro h1]: Enable set videoFullRange and BGR format -Disable HEVC bumping flag and h264 bumping flag as default -[HEVC]: Add error return to avoid segement fault -Support get color aspect info h264/hevc/mpeg2 decoder -Add security mode for VP9 Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
new file mode 100644
index 00000000..6fae1fe7
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
@@ -0,0 +1,34 @@
1# Copyright 2017-2018 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
11"
12SRC_URI[md5sum] = "51b811f9523d03ca87f611ba86594311"
13SRC_URI[sha256sum] = "cec620241d303852ddad8601f2025a68abbc1ec26d605103c7e4173749b59e3f"
14
15inherit fsl-eula-unpack use-imx-headers
16
17PARALLEL_MAKE="-j 1"
18
19PLATFORM_mx8mm = "IMX8MM"
20PLATFORM_mx8mq = "IMX8MQ"
21
22do_compile () {
23 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
24 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
25 PLATFORM="${PLATFORM}" all
26}
27
28do_install () {
29 oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
30}
31
32FILES_${PN} += "/unit_tests"
33
34COMPATIBLE_MACHINE = "(mx8m)"