summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
diff options
context:
space:
mode:
authorCristinel Panfir <cristinel.panfir@nxp.com>2019-12-16 15:50:08 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-16 11:28:41 -0300
commitdd2eaf55309c0b53839d05e57e4ecf968dced5d1 (patch)
tree6d51b2be561b20018733ee49271596f561c0d2b7 /recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
parent36e5b2fac8e4508807950dce6a524ee850a1532f (diff)
downloadmeta-freescale-dd2eaf55309c0b53839d05e57e4ecf968dced5d1.tar.gz
imx-vpu-hantro: Upgrade version from 1.11.0 to 1.15.0
- [H1]: code refine for error handling to avoid blocking - [H1]: Driver enhancement for suspend/resume - [ION]: Enhance for 32bit compatibility for decoder and encoder - [H264] Handle interlace video correctly - [VC1Dec] Return error to avoid segmentation fault - [H264]: decoder enhancment in h264bsdGetBits() for corrupted clips - [Common]: support for security mode Remove unused patch Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
deleted file mode 100644
index 3aeba4ac..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.11.0.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1# Copyright 2017-2018 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
11"
12SRC_URI[md5sum] = "51b811f9523d03ca87f611ba86594311"
13SRC_URI[sha256sum] = "cec620241d303852ddad8601f2025a68abbc1ec26d605103c7e4173749b59e3f"
14
15inherit fsl-eula-unpack use-imx-headers
16
17PARALLEL_MAKE="-j 1"
18
19PLATFORM_mx8mm = "IMX8MM"
20PLATFORM_mx8mq = "IMX8MQ"
21
22do_compile () {
23 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
24 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
25 PLATFORM="${PLATFORM}" all
26}
27
28do_install () {
29 oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
30}
31
32FILES_${PN} += "/unit_tests"
33
34COMPATIBLE_MACHINE = "(mx8m)"