summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-09-11 15:54:34 -0300
committerGitHub <noreply@github.com>2021-09-11 15:54:34 -0300
commit16e0d07d36787d14e9d00ff8123419863d1f19d2 (patch)
tree36a413f5702cd2d29b5023ec0762b71c27e4fac3 /recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
parent25e9cbddbd32802634bafef62ba08da9821c604d (diff)
parentb821d72e7b7fc250eb80fa43a79ce31b88863239 (diff)
downloadmeta-freescale-16e0d07d36787d14e9d00ff8123419863d1f19d2.tar.gz
Merge pull request #859 from angolini/hardknott+bsp
Backport NXP BSP 5.10.35_2.0.0 to Hardknott
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
new file mode 100644
index 00000000..58a140b4
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2019-2021 NXP
2
3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
6
7inherit fsl-eula-unpack
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11S = "${WORKDIR}/${BPN}-${PV}"
12
13SRC_URI[md5sum] = "b5270450ba2da5b7468b67ae8c0bcdca"
14SRC_URI[sha256sum] = "d5efae484c4271c098286d007590d6bf40c272d4f35702ff65625f2362715ab3"
15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES_${PN} = "/"
34
35COMPATIBLE_MACHINE = "(mx8mp)"