summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test/imx-test_git.bb
diff options
context:
space:
mode:
authorAlexandru Palalau <ioan-alexandru.palalau@nxp.com>2019-05-23 14:44:24 +0300
committerOtavio Salvador <otavio@ossystems.com.br>2019-06-13 14:06:41 -0300
commitf06d0e3c62f879c66292cde0fcd3f1de7ecca149 (patch)
tree94e67b3bd4777b152da9014696a0786c63eb26d0 /recipes-bsp/imx-test/imx-test_git.bb
parent760897e9a0fc9d5a262d2f601396c82bd6cd70b1 (diff)
downloadmeta-freescale-f06d0e3c62f879c66292cde0fcd3f1de7ecca149.tar.gz
imx-test: Switch to branch imx_4.14.98_2.0.0_ga
Signed-off-by: Alexandru Palalau <ioan-alexandru.palalau@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-test/imx-test_git.bb')
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb26
1 files changed, 11 insertions, 15 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index bf55f7df..084a2b04 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -1,6 +1,6 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
2# Copyright (C) 2013-2016 Freescale Semiconductor 2# Copyright (C) 2013-2016 Freescale Semiconductor
3# Copyright 2017-2018 NXP 3# Copyright (C) 2017-2019 NXP
4 4
5SUMMARY = "Test programs for i.MX BSP" 5SUMMARY = "Test programs for i.MX BSP"
6DESCRIPTION = "Unit tests for the i.MX BSP" 6DESCRIPTION = "Unit tests for the i.MX BSP"
@@ -16,13 +16,12 @@ DEPENDS_append_imxvpu = " virtual/imxvpu"
16PE = "1" 16PE = "1"
17PV = "7.0+${SRCPV}" 17PV = "7.0+${SRCPV}"
18 18
19SRCBRANCH = "imx_4.9.123_imx8mm_ga" 19SRCBRANCH = "imx_4.14.98_2.0.0_ga"
20SRC_URI = " \ 20SRC_URI = " \
21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
22 file://0001-test-Makefile-Add-include-path-to-CC-command.patch \
23 file://memtool_profile \ 22 file://memtool_profile \
24" 23"
25SRCREV = "2cc785f94e5ee8782083d941e6aef24952cc2a38" 24SRCREV = "d32727a9d7ef2543729c149a713db24b8f5c2aa8"
26S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
27 26
28inherit module-base use-imx-headers 27inherit module-base use-imx-headers
@@ -30,15 +29,15 @@ inherit module-base use-imx-headers
30INHIBIT_PACKAGE_STRIP = "1" 29INHIBIT_PACKAGE_STRIP = "1"
31INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 30INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
32 31
33PLATFORM_mx6q = "IMX6Q" 32PLATFORM_mx6q = "IMX6Q"
34PLATFORM_mx6dl = "IMX6Q" 33PLATFORM_mx6dl = "IMX6Q"
35PLATFORM_mx6sl = "IMX6SL" 34PLATFORM_mx6sl = "IMX6SL"
36PLATFORM_mx6sll = "IMX6SL" 35PLATFORM_mx6sll = "IMX6SL"
37PLATFORM_mx6sx = "IMX6SX" 36PLATFORM_mx6sx = "IMX6SX"
38PLATFORM_mx6ul = "IMX6UL" 37PLATFORM_mx6ul = "IMX6UL"
39PLATFORM_mx7d = "IMX7D" 38PLATFORM_mx7d = "IMX7D"
40PLATFORM_mx7ulp = "IMX7D" 39PLATFORM_mx7ulp = "IMX7D"
41PLATFORM_mx8 = "IMX8" 40PLATFORM_mx8 = "IMX8"
42 41
43PARALLEL_MAKE = "-j 1" 42PARALLEL_MAKE = "-j 1"
44EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" 43EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}"
@@ -49,9 +48,6 @@ PACKAGECONFIG_append_imxvpu = " vpu"
49PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" 48PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
50PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" 49PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu"
51 50
52# FIXME: NXP should fix the possible string flaws from their code.
53SECURITY_STRINGFORMAT = ""
54
55do_compile() { 51do_compile() {
56 CFLAGS="${TOOLCHAIN_OPTIONS}" 52 CFLAGS="${TOOLCHAIN_OPTIONS}"
57 oe_runmake V=1 VERBOSE='' \ 53 oe_runmake V=1 VERBOSE='' \