summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test/imx-test
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-08-05 08:50:26 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:14 -0300
commitd5e730317a4d1aa94bdfbf25654847fe788d70df (patch)
tree36c4c98296a7c073fa66a9bf938343ba63a9cf91 /recipes-bsp/imx-test/imx-test
parentb33e2a1f77655f625f3a4477a345991310af615b (diff)
downloadmeta-freescale-d5e730317a4d1aa94bdfbf25654847fe788d70df.tar.gz
Drop Freescale official Linux kernel for i.MX23, i.MX28 and i.MX5 SoC families
The Linux kernel provided by Freescale for i.MX28 and i.MX5 is too old (2.6.35.3) and there are no plans to upgrade it, as the OE-Core is going to use GCC 5.2 as default compiler soon and it is not possible to compile this kernel with the new toolchain, thus the removal. The metadata related to the i.MX23, i.MX28 and i.MX5 SoC family, which is dependant of this Linux kernel support, has been removed in this commit so if someone ever wants to bring it back it is easy to find out all the necessary changes. The recipes affected are: - alsa-state - amd-gpu-x11-bin - gtk+3 - imx-lib - imx-test - imx-vpu - libfslcodec - linux-imx - mesa - qt4-embedded-free - qt4-x11-free - qtbase - xf86-video-imxfb Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-bsp/imx-test/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch30
-rwxr-xr-xrecipes-bsp/imx-test/imx-test/clocks.sh29
-rw-r--r--recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch30
3 files changed, 0 insertions, 89 deletions
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
deleted file mode 100644
index 7497e91d..00000000
--- a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From fd826140db0f2a867ef588cccf2e5322cc77126a Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Mon, 19 Jan 2015 16:56:29 -0200
4Subject: [PATCH] Fix build in OpenEmbedded-Core environment
5Organization: O.S. Systems Software LTDA.
6
7Some of the unit-tests were not being built due to differences on how
8the build system behaves when running inside of the OE-Core. This
9fixes those minor issues and increases the number of tests available.
10
11Upstream-Status: Pending
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14
15diff --git a/test/ar3k_bt/Makefile b/test/ar3k_bt/Makefile
16index 92e2901..75d3e78 100755
17--- a/test/ar3k_bt/Makefile
18+++ b/test/ar3k_bt/Makefile
19@@ -21,7 +21,7 @@ all: $(OBJS)
20 CFLAGS += -lbluetooth
21
22 $(OBJDIR)/hciattach-ar3k.bin :
23- $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o hciattach-ar3k.bin
24+ $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o $(OBJDIR)/hciattach-ar3k.bin
25
26 clean:
27 rm -f *.o hciattach-ar3k.bin
28--
292.1.4
30
diff --git a/recipes-bsp/imx-test/imx-test/clocks.sh b/recipes-bsp/imx-test/imx-test/clocks.sh
deleted file mode 100755
index 2121bef6..00000000
--- a/recipes-bsp/imx-test/imx-test/clocks.sh
+++ /dev/null
@@ -1,29 +0,0 @@
1#!/bin/bash
2
3# This script is taken directly from the section 5.10 of the Freescale Application Note
4# AN4509 and it simple prints the CPU clocks in a nice format
5
6saved_path=$PWD
7if ! mount|grep -sq '/sys/kernel/debug'; then
8 mount -t debugfs none /sys/kernel/debug
9fi
10
11printf "%-24s %-20s %3s %9s\n" "clock" "parent" "use" "flags" "rate"
12
13for foo in $(find /sys/kernel/debug/clock -type d); do
14 if [ "$foo" = '/sys/kernel/debug/clock' ]; then
15 continue
16 fi
17 cd $foo
18 ec="$(cat usecount)"
19 rate="$(cat rate)"
20 flag="$(cat flags)"
21 clk="$(basename $foo)"
22 cd ..
23 parent="$(basename $PWD)"
24 if [ "$parent" = 'clock' ]; then
25 parent=" ---"
26 fi
27 printf "%-24s %-24s %2d %2d %10d\n" "$clk" "$parent" "$ec" "$flag" "$rate"
28 cd $saved_path
29done
diff --git a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch b/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch
deleted file mode 100644
index 4fb0564a..00000000
--- a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From e559eb0a9573b9011c03efaf42364dce67af893a Mon Sep 17 00:00:00 2001
2From: Lauren Post <lauren.post@freescale.com>
3Date: Tue, 10 Sep 2013 10:58:28 -0500
4Subject: [PATCH] ENGR00279068-2 epdc_test_driver: Update header name change
5 of mxc_epdc.h
6
7Upstream-Status: Pending
8
9Signed-off-by: Lauren Post <lauren.post@freescale.com>
10Signed-off-by: Frank Li <Frank.li@freescale.com>
11---
12 module_test/epdc_test_driver.c | 4 ++--
13 1 file changed, 1 insertions(+), 1 deletions(-)
14
15diff --git a/module_test/epdc_test_driver.c b/module_test/epdc_test_driver.c
16index fb15aec..447246f 100644
17--- a/module_test/epdc_test_driver.c
18+++ b/module_test/epdc_test_driver.c
19@@ -36,7 +36,7 @@
20
21 #include <linux/device.h>
22 #include <linux/mxcfb.h>
23-#include <linux/mxcfb_epdc.h>
24+#include <linux/mxcfb_epdc_kernel.h>
25
26 /* major number of device */
27 static int gMajor;
28--
291.7.9.5
30