diff options
author | Esben Haabendal <esben@geanix.com> | 2024-10-29 21:27:13 +0100 |
---|---|---|
committer | Esben Haabendal <esben@geanix.com> | 2024-10-29 21:44:49 +0100 |
commit | 7da235fbdd3dc521f5bfd368770b9a30b959e689 (patch) | |
tree | cd643a2e4052637b3f4fb960be54e7cd262169a1 /recipes-bsp/imx-mkimage | |
parent | 724fb423126f6d1ce7d0bc16799fd563ebcafecb (diff) | |
download | meta-freescale-7da235fbdd3dc521f5bfd368770b9a30b959e689.tar.gz |
imx-boot: Fix 8M non multi-config build problem
The fix made in commit 2db7047ba40e
("imx-boot: Fix 8M multi-config build problems")
broke builds not using U-Boot multi-config, as the link created ends up being a
simple recursive link when UBOOT_DTB_NAME_EXTRA is the same as UBOOT_DTB_NAME.
It fails with something like this:
```
| ./../scripts/dtb_check.sh imx8mq-evk.dtb evk.dtb imx8mq-var-dart-dt8mcustomboard.dtb
| Can't find u-boot DTB file, please copy from u-boot
```
caused by a symlink like this:
```
lrwxrwxrwx 1 esben 1000001 35 Oct 29 21:32 imx8mq-var-dart-dt8mcustomboard.dtb -> imx8mq-var-dart-dt8mcustomboard.dtb
```
Fixes: 2db7047ba40e ("imx-boot: Fix 8M multi-config build problems")
Signed-off-by: Esben Haabendal <esben@geanix.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index 3c027044..63857fa6 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -104,7 +104,9 @@ compile_mx8m() { | |||
104 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${UBOOT_DTB_NAME_EXTRA} \ | 104 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${UBOOT_DTB_NAME_EXTRA} \ |
105 | ${BOOT_STAGING} | 105 | ${BOOT_STAGING} |
106 | fi | 106 | fi |
107 | ln -sf ${UBOOT_DTB_NAME_EXTRA} ${BOOT_STAGING}/${UBOOT_DTB_NAME} | 107 | if [ "${UBOOT_DTB_NAME_EXTRA}" != "${UBOOT_DTB_NAME}" ] ; then |
108 | ln -sf ${UBOOT_DTB_NAME_EXTRA} ${BOOT_STAGING}/${UBOOT_DTB_NAME} | ||
109 | fi | ||
108 | 110 | ||
109 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \ | 111 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \ |
110 | ${BOOT_STAGING}/u-boot-nodtb.bin | 112 | ${BOOT_STAGING}/u-boot-nodtb.bin |