summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf_2.0.bb
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2019-10-25 11:04:01 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-11-08 15:31:25 -0300
commit2cbca9a255674649730b3f440a6142cf16030267 (patch)
treefea93a817d4c523b5822036363b885057ec3078c /recipes-bsp/imx-atf/imx-atf_2.0.bb
parentd331f7043142626ce2250ccd7f9a3e4791b1d377 (diff)
downloadmeta-freescale-2cbca9a255674649730b3f440a6142cf16030267.tar.gz
optee: Add support for optee imx fork to imx8mqevk
optee imx fork like most other imx forked components is more fully featured for imx devices and supports things like CAAM accleration. Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf_2.0.bb')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.0.bb b/recipes-bsp/imx-atf/imx-atf_2.0.bb
index 6a1ed74d..15122520 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.0.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.0.bb
@@ -30,16 +30,25 @@ EXTRA_OEMAKE += " \
30 PLAT=${PLATFORM} \ 30 PLAT=${PLATFORM} \
31" 31"
32 32
33BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
34
33do_compile() { 35do_compile() {
34 # Clear LDFLAGS to avoid the option -Wl recognize issue 36 # Clear LDFLAGS to avoid the option -Wl recognize issue
35 unset LDFLAGS 37 unset LDFLAGS
36 oe_runmake bl31 38 oe_runmake bl31
39 if ${BUILD_OPTEE}; then
40 oe_runmake clean BUILD_BASE=build-optee
41 oe_runmake BUILD_BASE=build-optee SPD=opteed bl31
42 fi
37} 43}
38 44
39do_install[noexec] = "1" 45do_install[noexec] = "1"
40 46
41do_deploy() { 47do_deploy() {
42 install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin 48 install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin
49 if ${BUILD_OPTEE}; then
50 install -m 0644 ${S}/build-optee/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin-optee
51 fi
43} 52}
44addtask deploy after do_compile 53addtask deploy after do_compile
45 54