summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-01-25 14:46:00 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-01-25 14:46:00 -0700
commite9b11f4ce4b786e777f506eb8764d2988f2841b7 (patch)
tree245b0e1badb5501dfe3233d2dfb8937a1df448ca /recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb
parentc552ece62de85e7fc6393c3397f4fbbc113dbd2d (diff)
downloadmeta-freescale-e9b11f4ce4b786e777f506eb8764d2988f2841b7.tar.gz
firmware-sof-imx: Upgrade 2.2.0 -> 2.3.0
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb')
-rw-r--r--recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb b/recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb
new file mode 100644
index 00000000..9778bd1c
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-sof-imx_2.3.0.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2020-2022 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Sound Open Firmware"
5HOMEPAGE = "https://www.sofproject.org"
6SECTION = "base"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=0f00d99239d922ffd13cabef83b33444"
9
10SRC_URI = "${FSL_MIRROR}/sof-imx-${PV}.tar.gz"
11SRC_URI[md5sum] = "f7d277717b3f0dd17e8d341c1091d6b6"
12SRC_URI[sha256sum] = "eb86c90aec92b3b376e7afca6aa5db4767b5d8868553595907ba37665329f16b"
13
14S = "${WORKDIR}/sof-imx-${PV}"
15
16inherit allarch
17
18do_install() {
19 # Install sof and sof-tplg folder
20 install -d ${D}${nonarch_base_libdir}/firmware/imx/
21 cp -r sof* ${D}${nonarch_base_libdir}/firmware/imx/
22}
23
24FILES:${PN} = "${nonarch_base_libdir}/firmware/imx"