summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-08-31 08:27:12 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:42:37 -0300
commitb3eff3e4cea333e35401e031293731ab32bc0929 (patch)
treeb3108cbaf19d1b093014d52dbd4fd2a54b3e0b92 /recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb
parent4ff5c74607d49d40898bc18416365f7a050651aa (diff)
downloadmeta-freescale-b3eff3e4cea333e35401e031293731ab32bc0929.tar.gz
firmware-imx: upgrade to version 8.8
Update all recipe PN to match the one from upstream. Latest delivery from NXP has VPU firmware for imx27 in the package, so enable it to be included in the image. It also also lacks the VPU firmware for imx8qxp, so disable the package for now until it is provided from NXP. firmware-imx has been re-worked to provide a more unified mechanism for installing firmware files into ${D} and package split is expalined in the comments section. NOTE: This update uses new EULA v11 from NXP. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb b/recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb
new file mode 100644
index 00000000..44e9ff4a
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-imx-8m_8.8.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2018-2020 NXP
2SUMMARY = "Freescale i.MX firmware for 8M and 8M Mini family"
3DESCRIPTION = "Freescale i.MX firmware for 8M and 8M Mini family"
4
5require firmware-imx-${PV}.inc
6
7inherit deploy
8
9do_install[noexec] = "1"
10
11do_deploy() {
12 # Synopsys DDR
13 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
14 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
15 done
16 # Cadence DP and HDMI
17 install -m 0644 ${S}/firmware/hdmi/cadence/signed_dp_imx8m.bin ${DEPLOYDIR}
18 install -m 0644 ${S}/firmware/hdmi/cadence/signed_hdmi_imx8m.bin ${DEPLOYDIR}
19}
20addtask deploy after do_install before do_build
21
22PACKAGE_ARCH = "${MACHINE_SOCARCH}"
23
24COMPATIBLE_MACHINE = "(mx8m)"