summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf/qoriq-atf-tools_2.6.bb
diff options
context:
space:
mode:
authorJun Zhu <junzhu@nxp.com>2023-04-17 18:51:34 +0800
committerJun Zhu <junzhu@nxp.com>2023-04-17 10:44:22 +0800
commit88c9f817bd344438a3739ab4235b2e28b729a5f4 (patch)
treed4c54456d3b03555877fb86f0c78132f52b1731c /recipes-bsp/atf/qoriq-atf-tools_2.6.bb
parent5dd6bfebacd3bbae8b824fff20d426cd14249459 (diff)
downloadmeta-freescale-88c9f817bd344438a3739ab4235b2e28b729a5f4.tar.gz
qoriq-atf: Upgrade to v2.6
Signed-off-by: Jun Zhu <junzhu@nxp.com>
Diffstat (limited to 'recipes-bsp/atf/qoriq-atf-tools_2.6.bb')
-rw-r--r--recipes-bsp/atf/qoriq-atf-tools_2.6.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/atf/qoriq-atf-tools_2.6.bb b/recipes-bsp/atf/qoriq-atf-tools_2.6.bb
new file mode 100644
index 00000000..2c1db306
--- /dev/null
+++ b/recipes-bsp/atf/qoriq-atf-tools_2.6.bb
@@ -0,0 +1,15 @@
1require qoriq-atf-${PV}.inc
2
3DEPENDS += "openssl"
4
5PV:append = "+${SRCPV}"
6
7EXTRA_OEMAKE = "fiptool V=1 PLAT=lx2162aqds HOSTCC='${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}'"
8
9do_install () {
10 install -m 0755 -d ${D}/${bindir}
11 install -m 0755 ${S}/tools/fiptool/fiptool ${D}/${bindir}/
12}
13
14BBCLASSEXTEND = "native"
15