diff options
author | Ting Liu <ting.liu@freescale.com> | 2014-05-27 00:56:34 -0500 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2014-07-08 18:14:47 +0800 |
commit | 42c28f6012548be9838d21e41be24994dc619fad (patch) | |
tree | f7ae9e6769aeefbd97ead4d2bd20572bd7e5568c /meta-fsl-ppc/recipes-virtualization | |
parent | ad18b996adf16e52142c7e48dbe7d5cacee62548 (diff) | |
download | meta-freescale-42c28f6012548be9838d21e41be24994dc619fad.tar.gz |
hypervisor: use seperate folder for 32/64b output
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Diffstat (limited to 'meta-fsl-ppc/recipes-virtualization')
-rw-r--r-- | meta-fsl-ppc/recipes-virtualization/hypervisor/hypervisor_git.bb | 25 |
1 files changed, 14 insertions, 11 deletions
diff --git a/meta-fsl-ppc/recipes-virtualization/hypervisor/hypervisor_git.bb b/meta-fsl-ppc/recipes-virtualization/hypervisor/hypervisor_git.bb index 318c9422..14aaedf3 100644 --- a/meta-fsl-ppc/recipes-virtualization/hypervisor/hypervisor_git.bb +++ b/meta-fsl-ppc/recipes-virtualization/hypervisor/hypervisor_git.bb | |||
@@ -9,8 +9,6 @@ DEPENDS = "u-boot-mkimage-native" | |||
9 | 9 | ||
10 | inherit deploy | 10 | inherit deploy |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | # TODO: fix dtc to use the already built package | 12 | # TODO: fix dtc to use the already built package |
15 | SRC_URI = " \ | 13 | SRC_URI = " \ |
16 | git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;nobranch=1 \ | 14 | git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;nobranch=1 \ |
@@ -30,7 +28,12 @@ SRCREV_libos = "4691387e15be78d140142104f30b3f356281c46a" | |||
30 | SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0" | 28 | SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0" |
31 | SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533" | 29 | SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533" |
32 | 30 | ||
33 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' | 31 | S = "${WORKDIR}/git" |
32 | |||
33 | OUTPUT ?= "output32" | ||
34 | OUTPUT_powerpc64 = "output64" | ||
35 | |||
36 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" O="${OUTPUT}"' | ||
34 | 37 | ||
35 | DEFCONFIG = "defconfig" | 38 | DEFCONFIG = "defconfig" |
36 | DEFCONFIG_powerpc64 = "64bit_defconfig" | 39 | DEFCONFIG_powerpc64 = "64bit_defconfig" |
@@ -60,29 +63,29 @@ do_compile () { | |||
60 | 63 | ||
61 | do_install () { | 64 | do_install () { |
62 | install -d ${D}/${bindir} | 65 | install -d ${D}/${bindir} |
63 | install ${S}/output/bin/linux/partman ${D}/${bindir}/partman | 66 | install ${B}/${OUTPUT}/bin/linux/partman ${D}/${bindir}/partman |
64 | 67 | ||
65 | install -d ${D}${sysconfdir}/udev/rules.d | 68 | install -d ${D}${sysconfdir}/udev/rules.d |
66 | install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d | 69 | install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d |
67 | 70 | ||
68 | install -d ${D}/boot/hv | 71 | install -d ${D}/boot/hv |
69 | install ${S}/output/.config ${D}/boot/hv/hypervisor.config | 72 | install ${B}/${OUTPUT}/.config ${D}/boot/hv/hypervisor.config |
70 | install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \ | 73 | install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \ |
71 | ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \ | 74 | ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \ |
72 | ${D}/boot/hv/ | 75 | ${D}/boot/hv/ |
73 | } | 76 | } |
74 | 77 | ||
75 | do_deploy () { | 78 | do_deploy () { |
76 | install -d ${DEPLOYDIR}/hv/ | 79 | install -d ${DEPLOYDIR}/hv/ |
77 | install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config | 80 | install ${B}/${OUTPUT}/.config ${DEPLOYDIR}/hv/hypervisor.config |
78 | install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \ | 81 | install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \ |
79 | ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \ | 82 | ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \ |
80 | ${DEPLOYDIR}/hv/ | 83 | ${DEPLOYDIR}/hv/ |
81 | } | 84 | } |
82 | addtask deploy before do_build after do_install | 85 | addtask deploy before do_build after do_install |
83 | 86 | ||
84 | do_deploy_append() { | 87 | do_deploy_append() { |
85 | rm -f ${S}/../hv | 88 | rm -f ${B}/../hv |
86 | } | 89 | } |
87 | 90 | ||
88 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 91 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |