summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-08-28 09:43:01 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2018-08-30 21:58:01 -0300
commit99f8b01e9c4667bd2fcf5d8f6305aae3fcb1a770 (patch)
tree55f4a9ad2ca719def17ae00831b15c03a7aebe20 /dynamic-layers
parent5c0245a4dc5e8d8b522d408a71d848ecf3ab88b3 (diff)
downloadmeta-freescale-99f8b01e9c4667bd2fcf5d8f6305aae3fcb1a770.tar.gz
qtwebkit: remove 0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch
* it does not apply with meta-qt5 master * it changes (breaks currently) qtwebkit for all boards when adding meta-freescale to layers Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch42
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend4
2 files changed, 0 insertions, 46 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch
deleted file mode 100644
index 80e55c7f..00000000
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 66dab98c3f42eb70a4c6761a8694e374b8578e99 Mon Sep 17 00:00:00 2001
2From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com>
3Date: Thu, 8 May 2014 09:27:04 -0700
4Subject: [PATCH] Fix to match the uniform precision qualifiers in vertex and
5 fragment shaders
6
7When the vertex and fragment shaders are linked together, then they will
8share a single global uniform name space. Hence, types and precisions of
9uniforms with the same name must match across all shaders that are linked
10into a single executable.
11
12As per GLSL_ES_Specification_3.00.3.pdf
13Page 124 12.3 Numeric Precision
14The fragment language has no default precision qualifier for floating point types.
15Hence for float, floating point vector and matrix variable declarations, either
16the declaration must include a precision qualifier or the default float
17precision must have been previously declared.
18
19Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=124653#c9]
20
21Change-Id: I4eb3363b3bca8bc3c839212ec7c966201a3e65e2
22Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com>
23---
24 Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-)
26
27diff --git a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp
28index f4b9a7e..7e991bf 100644
29--- a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp
30+++ b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp
31@@ -208,7 +208,7 @@ static const char* fragmentTemplate =
32 ANTIALIASING_TEX_COORD_DIRECTIVE
33 BLUR_CONSTANTS
34 STRINGIFY(
35- precision mediump float;
36+ precision highp float;
37 uniform SamplerType s_sampler;
38 uniform sampler2D s_contentTexture;
39 uniform float u_opacity;
40--
411.9.1
42
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend
deleted file mode 100644
index 5d961e64..00000000
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch"
4