summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-02 11:01:05 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:24 -0700
commit59d36c9832702989bfcca8a5af29fb2dff01efcc (patch)
treeb2b07d98cb22bc5241cde7403b6a15d99821318e /dynamic-layers
parent72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff)
downloadmeta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend2
-rw-r--r--dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc4
-rw-r--r--dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend2
-rw-r--r--dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend2
-rw-r--r--dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend2
-rw-r--r--dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend2
-rw-r--r--dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend6
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend4
-rw-r--r--dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb18
-rw-r--r--dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend6
-rw-r--r--dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc12
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend26
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend8
-rw-r--r--dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend8
14 files changed, 51 insertions, 51 deletions
diff --git a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend
index 10b66c0e..b7bf3298 100644
--- a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend
+++ b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend
@@ -1,3 +1,3 @@
1do_install_append() { 1do_install:append() {
2 rm -f ${D}${sysconfdir}/xdg/weston/weston.ini 2 rm -f ${D}${sysconfdir}/xdg/weston/weston.ini
3} 3}
diff --git a/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc
index cdd0f08f..7d8065f9 100644
--- a/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc
+++ b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc
@@ -1,4 +1,4 @@
1DEPENDS_append_imxvpu = " imx-vpuwrap" 1DEPENDS:append:imxvpu = " imx-vpuwrap"
2 2
3# Additional imx code and patches are included in the chromium-imx git repository. 3# Additional imx code and patches are included in the chromium-imx git repository.
4# The code below fetches this repository, copies the extra source over to the main 4# The code below fetches this repository, copies the extra source over to the main
@@ -26,7 +26,7 @@ do_patch[prefuncs] =+ "add_chromium_imx_patches"
26# * Lost context problems are not known to happen with Vivante GPUs, 26# * Lost context problems are not known to happen with Vivante GPUs,
27# so it is safe to use ignore-lost-context 27# so it is safe to use ignore-lost-context
28# * Proprietary codecs need to be enabled for h.264 and MP4 support 28# * Proprietary codecs need to be enabled for h.264 and MP4 support
29PACKAGECONFIG_append = " ignore-lost-context proprietary-codecs" 29PACKAGECONFIG:append = " ignore-lost-context proprietary-codecs"
30 30
31copy_chromium_imx_files() { 31copy_chromium_imx_files() {
32 # sources in src/ are already organized in a manner 32 # sources in src/ are already organized in a manner
diff --git a/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend b/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend
index 1080a9f5..563c9e76 100644
--- a/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend
+++ b/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend
@@ -4,7 +4,7 @@ PACKAGES += " \
4 ${PN}-f2fs \ 4 ${PN}-f2fs \
5" 5"
6 6
7RDEPENDS_${PN}-f2fs = " \ 7RDEPENDS:${PN}-f2fs = " \
8 ${PN}-base \ 8 ${PN}-base \
9 f2fs-tools \ 9 f2fs-tools \
10" 10"
diff --git a/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend b/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend
index 0b4c4861..fb90c73e 100644
--- a/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend
+++ b/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend
@@ -1,4 +1,4 @@
1PACKAGECONFIG_imxgpu3d ??= " \ 1PACKAGECONFIG:imxgpu3d ??= " \
2 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', \ 2 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', \
3 bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11', \ 3 bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11', \
4 '', d), d)} \ 4 '', d), d)} \
diff --git a/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend b/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend
index afbaee43..e07d0d54 100644
--- a/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend
+++ b/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend
@@ -1,4 +1,4 @@
1PACKAGECONFIG_imxgpu3d ??= " \ 1PACKAGECONFIG:imxgpu3d ??= " \
2 cogl-pango gles2 \ 2 cogl-pango gles2 \
3 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'egl-wayland', \ 3 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'egl-wayland', \
4 bb.utils.contains('DISTRO_FEATURES', 'x11', 'egl-x11', \ 4 bb.utils.contains('DISTRO_FEATURES', 'x11', 'egl-x11', \
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend
index 72d991c7..4fc41d05 100644
--- a/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend
+++ b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend
@@ -1 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
index 2e648ba3..998d11f7 100644
--- a/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
+++ b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
@@ -1,4 +1,4 @@
1# Only _mx8 machine do provide virtual/libgbm required for any drm* flavour 1# Only _mx8 machine do provide virtual/libgbm required for any drm* flavour
2DRM-REMOVE_imxgpu = "drm-gl drm-gles2" 2DRM-REMOVE:imxgpu = "drm-gl drm-gles2"
3DRM-REMOVE_imxgpu_mx8 = "" 3DRM-REMOVE:imxgpu:mx8 = ""
4PACKAGECONFIG_remove = "${DRM-REMOVE}" 4PACKAGECONFIG:remove = "${DRM-REMOVE}"
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend
index 8c6138c5..d07f8ae1 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
2 2
3SRC_URI_append_qoriq-ppc = " file://ppc-fixplt.patch " 3SRC_URI:append:qoriq-ppc = " file://ppc-fixplt.patch "
4 4
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb
index 1793ec06..9c6be782 100644
--- a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb
+++ b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb
@@ -19,15 +19,15 @@ EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING
19 TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' 19 TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
20 20
21EXTRA_OEMAKE_PLATFORM ?= "" 21EXTRA_OEMAKE_PLATFORM ?= ""
22EXTRA_OEMAKE_PLATFORM_ls1043a = "ls1043" 22EXTRA_OEMAKE_PLATFORM:ls1043a = "ls1043"
23EXTRA_OEMAKE_PLATFORM_ls1046a = "ls1046" 23EXTRA_OEMAKE_PLATFORM:ls1046a = "ls1046"
24EXTRA_OEMAKE_PLATFORM_ls1088a = "ls1088" 24EXTRA_OEMAKE_PLATFORM:ls1088a = "ls1088"
25EXTRA_OEMAKE_PLATFORM_p1020 = "p4080ds" 25EXTRA_OEMAKE_PLATFORM:p1020 = "p4080ds"
26EXTRA_OEMAKE_PLATFORM_p2020 = "p4080ds" 26EXTRA_OEMAKE_PLATFORM:p2020 = "p4080ds"
27EXTRA_OEMAKE_PLATFORM_p2041 = "p4080ds" 27EXTRA_OEMAKE_PLATFORM:p2041 = "p4080ds"
28EXTRA_OEMAKE_PLATFORM_p3041 = "p4080ds" 28EXTRA_OEMAKE_PLATFORM:p3041 = "p4080ds"
29EXTRA_OEMAKE_PLATFORM_p4080 = "p4080ds" 29EXTRA_OEMAKE_PLATFORM:p4080 = "p4080ds"
30EXTRA_OEMAKE_PLATFORM_p5040 = "p4080ds" 30EXTRA_OEMAKE_PLATFORM:p5040 = "p4080ds"
31 31
32 32
33do_compile () { 33do_compile () {
diff --git a/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend
index f4f43504..be694574 100644
--- a/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend
+++ b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend
@@ -1,8 +1,8 @@
1# i.MX extra configuration 1# i.MX extra configuration
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 2FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
3 3
4SRC_URI_append_imxgpu3d = " \ 4SRC_URI:append:imxgpu3d = " \
5 file://0016-xserver-common-enable-iglx-module.patch \ 5 file://0016-xserver-common-enable-iglx-module.patch \
6" 6"
7 7
8PACKAGE_ARCH_imxgpu3d = "${MACHINE_SOCARCH}" 8PACKAGE_ARCH:imxgpu3d = "${MACHINE_SOCARCH}"
diff --git a/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc b/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
index 187681a8..8950c151 100644
--- a/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
+++ b/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/qt4:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/qt4:"
2 2
3python __anonymous () { 3python __anonymous () {
4 families = ['mx6'] 4 families = ['mx6']
@@ -8,21 +8,21 @@ python __anonymous () {
8 d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir') 8 d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir')
9} 9}
10 10
11SRC_URI_append_imxgpu2d += " \ 11SRC_URI:append:imxgpu2d += " \
12 file://0001-Add-support-for-i.MX-codecs-to-phonon.patch \ 12 file://0001-Add-support-for-i.MX-codecs-to-phonon.patch \
13 file://0002-i.MX-video-renderer-Allow-v4l-device-from-environmen.patch \ 13 file://0002-i.MX-video-renderer-Allow-v4l-device-from-environmen.patch \
14 file://0003-i.MX6-force-egl-visual-ID-33.patch \ 14 file://0003-i.MX6-force-egl-visual-ID-33.patch \
15" 15"
16 16
17DEPENDS_append_imxgpu2d = " virtual/kernel virtual/libgles2" 17DEPENDS:append:imxgpu2d = " virtual/kernel virtual/libgles2"
18QT_GLFLAGS_imxgpu2d = "-opengl es2 -openvg" 18QT_GLFLAGS:imxgpu2d = "-opengl es2 -openvg"
19QT_CONFIG_FLAGS_append_imxgpu2d = " -I${STAGING_KERNEL_DIR}/include/uapi \ 19QT_CONFIG_FLAGS:append:imxgpu2d = " -I${STAGING_KERNEL_DIR}/include/uapi \
20 -I${STAGING_KERNEL_DIR}/include/ \ 20 -I${STAGING_KERNEL_DIR}/include/ \
21 -DLINUX=1 -DEGL_API_FB=1 \ 21 -DLINUX=1 -DEGL_API_FB=1 \
22 -DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1" 22 -DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1"
23 23
24# The QT_CONFIG_FLAGS can pollute *.la files with -Dxxx 24# The QT_CONFIG_FLAGS can pollute *.la files with -Dxxx
25do_compile_append_mx6 () { 25do_compile:append:mx6 () {
26 find lib -name "*.la" | xargs -n1 sed -i 's/-D.*=1//g' 26 find lib -name "*.la" | xargs -n1 sed -i 's/-D.*=1//g'
27} 27}
28 28
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index bf3fb66e..0d5897ad 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -3,35 +3,35 @@
3# Copyright (C) 2016, 2017 O.S. Systems Software LTDA. 3# Copyright (C) 2016, 2017 O.S. Systems Software LTDA.
4# Copyright (C) 2017-2018 NXP 4# Copyright (C) 2017-2018 NXP
5 5
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 6FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
7 7
8SRC_URI_append_imxgpu = " \ 8SRC_URI:append:imxgpu = " \
9 file://0014-Add-IMX-GPU-support.patch \ 9 file://0014-Add-IMX-GPU-support.patch \
10 file://0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch \ 10 file://0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch \
11" 11"
12 12
13PACKAGECONFIG_GL_IMX_GPU = "" 13PACKAGECONFIG_GL_IMX_GPU = ""
14PACKAGECONFIG_GL_IMX_GPU_mx8 = "gbm kms" 14PACKAGECONFIG_GL_IMX_GPU:mx8 = "gbm kms"
15 15
16PACKAGECONFIG_GL_imxpxp = "gles2" 16PACKAGECONFIG_GL:imxpxp = "gles2"
17PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \ 17PACKAGECONFIG_GL:imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \
18 ${PACKAGECONFIG_GL_IMX_GPU}" 18 ${PACKAGECONFIG_GL_IMX_GPU}"
19PACKAGECONFIG_GL_imxgpu3d = "gles2 \ 19PACKAGECONFIG_GL:imxgpu3d = "gles2 \
20 ${PACKAGECONFIG_GL_IMX_GPU}" 20 ${PACKAGECONFIG_GL_IMX_GPU}"
21PACKAGECONFIG_GL_use-mainline-bsp ?= "gles2 gbm kms" 21PACKAGECONFIG_GL:use-mainline-bsp ?= "gles2 gbm kms"
22 22
23PACKAGECONFIG_PLATFORM = "" 23PACKAGECONFIG_PLATFORM = ""
24PACKAGECONFIG_PLATFORM_imxgpu2d = "no-opengl linuxfb" 24PACKAGECONFIG_PLATFORM:imxgpu2d = "no-opengl linuxfb"
25PACKAGECONFIG_PLATFORM_imxgpu3d = " \ 25PACKAGECONFIG_PLATFORM:imxgpu3d = " \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ 26 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
27 bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ 27 bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
28 'eglfs', d), d)}" 28 'eglfs', d), d)}"
29PACKAGECONFIG_PLATFORM_use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}" 29PACKAGECONFIG_PLATFORM:use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}"
30PACKAGECONFIG += "${PACKAGECONFIG_PLATFORM}" 30PACKAGECONFIG += "${PACKAGECONFIG_PLATFORM}"
31 31
32PACKAGECONFIG_VULKAN_IMX_GPU = "" 32PACKAGECONFIG_VULKAN_IMX_GPU = ""
33PACKAGECONFIG_VULKAN_IMX_GPU_mx8 = "vulkan" 33PACKAGECONFIG_VULKAN_IMX_GPU:mx8 = "vulkan"
34PACKAGECONFIG_VULKAN_IMX_GPU_mx8mm = "" 34PACKAGECONFIG_VULKAN_IMX_GPU:mx8mm = ""
35PACKAGECONFIG_VULKAN = "" 35PACKAGECONFIG_VULKAN = ""
36PACKAGECONFIG_VULKAN_imxgpu = "${PACKAGECONFIG_VULKAN_IMX_GPU}" 36PACKAGECONFIG_VULKAN:imxgpu = "${PACKAGECONFIG_VULKAN_IMX_GPU}"
37PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}" 37PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}"
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
index 168db095..c1594e05 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
@@ -1,8 +1,8 @@
1# etnaviv mesa does not have glx 1# etnaviv mesa does not have glx
2PACKAGECONFIG_remove_use-mainline-bsp = "xcomposite-glx" 2PACKAGECONFIG:remove:use-mainline-bsp = "xcomposite-glx"
3 3
4PACKAGECONFIG_remove_mx6 = "xcomposite-egl xcomposite-glx" 4PACKAGECONFIG:remove:mx6 = "xcomposite-egl xcomposite-glx"
5PACKAGECONFIG_remove_mx7 = "xcomposite-egl xcomposite-glx" 5PACKAGECONFIG:remove:mx7 = "xcomposite-egl xcomposite-glx"
6 6
7# i.MX8 does never provide native x11, so required dependencies are not met 7# i.MX8 does never provide native x11, so required dependencies are not met
8PACKAGECONFIG_remove_mx8 = "xcomposite-egl xcomposite-glx" 8PACKAGECONFIG:remove:mx8 = "xcomposite-egl xcomposite-glx"
diff --git a/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend b/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend
index c7e6d32e..f64637bd 100644
--- a/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend
+++ b/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend
@@ -1,9 +1,9 @@
1PACKAGECONFIG_qoriq-ppc = "qemu yajl lxc test remote macvtap libvirtd netcf udev python" 1PACKAGECONFIG:qoriq-ppc = "qemu yajl lxc test remote macvtap libvirtd netcf udev python"
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" 3FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
4SRC_URI_append_qoriq-ppc = " file://qemu.conf" 4SRC_URI:append:qoriq-ppc = " file://qemu.conf"
5 5
6do_install_append_qoriq-ppc() { 6do_install:append:qoriq-ppc() {
7 install -m 0644 ${WORKDIR}/qemu.conf ${D}${sysconfdir}/libvirt/qemu.conf 7 install -m 0644 ${WORKDIR}/qemu.conf ${D}${sysconfdir}/libvirt/qemu.conf
8} 8}
9 9