summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/qt5-layer
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-11-15 16:30:07 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2016-11-18 16:23:08 -0200
commite80e2b0af842d19365769b6e0e4e3b621134d51b (patch)
treee57bef50f9d42a71441588a4fb658e487233a070 /dynamic-layers/qt5-layer
parent9497793b288caa2c26d1f7f9538cbfd281de1134 (diff)
downloadmeta-freescale-e80e2b0af842d19365769b6e0e4e3b621134d51b.tar.gz
qtbase: do not pass -DEGL_API_FB=1 for x11 in distro features
* sympthoms: * qml applications complain/crash with 'Failed to create OpenGL context...' * qt5-opengles2-test hangs forever without displaying anything * analysis: qtbase's configure complains: <...>/usr/include/EGL/eglvivante.h:117:16: note: class type '_FBDisplay' is incomplete and configure ends up with no X11 support: EGLFS ................ no EGLFS i.MX6 ........ no EGLFS i.MX6 Wayland. no EGLFS EGLDevice .... no EGLFS GBM .......... no EGLFS Mali ......... no EGLFS Raspberry Pi . no EGLFS X11 .......... no LinuxFB .............. no Mir client............ no XCB .................. yes (system library) EGL on X ........... no * background: '-DEGL_API_FB=1' was introduced in commit 62c8d8cc6500711464049662489729f208240be8 Author: Martin Jansa <martin.jansa@gmail.com> Date: Mon Feb 29 18:22:28 2016 +0100 qtbase: Allow to build eglfs with x11 in DISTRO_FEATURES * even when x11 is in DISTRO_FEATURES someone might configure qtbase to build with eglfs, that works OK with Qt 5.5.1, because -DEGL_API_FB=1 is also passed through mkspecs/devices/linux-imx6-g++/qmake.conf but with 5.6 and 5.7 it fails when X11 headers are include with their own Status enum (the same errors like before https://codereview.qt-project.org/#/c/105116/2) Adding -DEGL_API_FB=1 like linux-imx6-g++/qmake.conf does is simplest workaround to prevent imx-gpu-viv from including Xlib from EGL/eglvivante.h * comments on original commit (at today's' environment): * it breaks GL support for X11 * in meta-freescale's qtbase.bbappend eglfs is disabled explicitly when x11 in DISTRO_FEATURES so it seems that vivante driver does not support eglfs and x11 at the same build. Tested: setting 'eglfs' in PACKAGECONFIG builds fine but bare eglfs support is skipped. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/qt5-layer')
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 178d80d5..f5064a84 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -33,7 +33,7 @@ EOF
33 fi 33 fi
34 else 34 else
35 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 35 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
36IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 36IMX6_CFLAGS = -DLINUX=1
37EOF 37EOF
38 fi 38 fi
39 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 39 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF