summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/qt5-layer
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-10-11 11:13:26 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-11-06 10:16:34 -0200
commit33a9e621812db54613408da065fa1b3aeb0f1aa8 (patch)
treed89e7b692f12d40c22396e338c4451d0918fe641 /dynamic-layers/qt5-layer
parent9693f8c4d163824b4b3519c4123e154870c50c87 (diff)
downloadmeta-freescale-33a9e621812db54613408da065fa1b3aeb0f1aa8.tar.gz
qtbase: Set the default platform correctly
Set the correct Qt platform for the graphics backend so the user isn't required to set it manually. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'dynamic-layers/qt5-layer')
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index b84e3d49..d6f3b109 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -28,3 +28,8 @@ QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11'
28QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '-no-eglfs', '-eglfs', d)}" 28QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '-no-eglfs', '-eglfs', d)}"
29QT_CONFIG_FLAGS_APPEND_use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '-no-eglfs', '-eglfs', d)}" 29QT_CONFIG_FLAGS_APPEND_use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '-no-eglfs', '-eglfs', d)}"
30QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" 30QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}"
31
32QT_CONFIG_FLAGS += \
33 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '-qpa wayland', \
34 bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
35 '-qpa eglfs', d), d)}"