summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/qt5-layer
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-10-18 14:01:38 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-26 14:06:46 -0300
commit1cf9efd20fd94afdd2f7484b0570c570a21b8b65 (patch)
tree2e3137de1c3adb7f16fac24adbd6274845c556a5 /dynamic-layers/qt5-layer
parent03d5ab3f4766264abbfffb0e6cb15ccc267d215d (diff)
downloadmeta-freescale-1cf9efd20fd94afdd2f7484b0570c570a21b8b65.tar.gz
qtbase: Do not pin gles2 when using open source graphic stack
One of the advantages in using upstream mesa is that we have the freedom to use gl or gles2 for qtbase. So follow meta-qt5's default here which is desktop-gl and give other layers a more simple chance to change default if necessary. Notes: * Did performance tests with my images and did not find any performance issues. * Some recipes in meta-qt5-extra fail to build when qtbase is build for gles2. A patch addressing imx was applied [1] - but honestly it is not the way to go: use meta-qt5's default which is fine. [1] https://github.com/schnitzeltony/meta-qt5-extra/commit/0972828deb6a9e6a44d7596e6e4817fd74dbb51c Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/qt5-layer')
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 6d74ea6c..47b0a143 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -17,7 +17,7 @@ SRC_URI_append_imxgpu3d = " \
17PACKAGECONFIG_GL_imxpxp = "gles2" 17PACKAGECONFIG_GL_imxpxp = "gles2"
18PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" 18PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}"
19PACKAGECONFIG_GL_imxgpu3d = "gles2" 19PACKAGECONFIG_GL_imxgpu3d = "gles2"
20PACKAGECONFIG_GL_use-mainline-bsp = "gbm gles2 kms" 20PACKAGECONFIG_GL_append_use-mainline-bsp = " gbm kms"
21 21
22QT_CONFIG_FLAGS_APPEND = "" 22QT_CONFIG_FLAGS_APPEND = ""
23QT_CONFIG_FLAGS_APPEND_imxpxp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '-no-eglfs', '-eglfs', d)}" 23QT_CONFIG_FLAGS_APPEND_imxpxp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '-no-eglfs', '-eglfs', d)}"