summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:21:16 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitca38cdc4de1143cf6b7af76e9426ecf31f0922f0 (patch)
tree01db34465457c4b22036f27dba53d55f01ef6d03 /dynamic-layers/openembedded-layer
parentb6e2300960729d67720e1e626051999ca7a7009f (diff)
downloadmeta-freescale-ca38cdc4de1143cf6b7af76e9426ecf31f0922f0.tar.gz
Move external layer's specific changes for 'dynamic-layers' subdir
The external layer's specific changes are now in the 'dynamic-layers' subdirectory. This approach ease the identification of layer specific recipes and extensions as all those are more visible isolated of the main layer components. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend3
-rw-r--r--dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch46
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend3
4 files changed, 85 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
new file mode 100644
index 00000000..8e57d663
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
@@ -0,0 +1,3 @@
1#Remove gles2 as it is not supported by sololite
2
3PACKAGECONFIG_remove_mx6sl = "gles2"
diff --git a/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb b/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 00000000..7cf8f57a
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
7SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
8
9inherit module
10
11S = "${WORKDIR}/git/asfmodule"
12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18do_configure[depends] += "virtual/kernel:do_shared_workdir"
19do_configure_prepend () {
20 find ${S} -name Makefile -exec \
21 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
22}
23
24do_install(){
25 mkdir -p ${D}/${libexecdir}
26 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
27 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
28 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/../scripts ${D}/${libexecdir}/
30}
31
32FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
33RDEPENDS_${PN} += "ipsec-tools"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
new file mode 100644
index 00000000..274fbe74
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
@@ -0,0 +1,46 @@
1From 90f869763026e8ff18aeecde217d778f00e4f294 Mon Sep 17 00:00:00 2001
2From: Shawn Xiao <b49994@freescale.com>
3Date: Tue, 10 Feb 2015 16:11:59 +0800
4Subject: [PATCH] MGS-515 [#ccc] Opencv app can't run on imx6sx with cam
5
6This issue is caused by the no support of VIDIOC_QUERYCTRL ioctl
7item in latest cam driver.
8
9Modified the errno in check logic to compatible with new driver.
10
11Feb 10, 2015
12
13Upstream-Status: Pending
14
15Signed-off-by: Shawn Xiao <b49994@freescale.com>
16---
17 modules/highgui/src/cap_v4l.cpp | 6 ++++--
18 1 file changed, 4 insertions(+), 2 deletions(-)
19
20diff --git a/modules/highgui/src/cap_v4l.cpp b/modules/highgui/src/cap_v4l.cpp
21index c9fca05..8c46b6c 100644
22--- a/modules/highgui/src/cap_v4l.cpp
23+++ b/modules/highgui/src/cap_v4l.cpp
24@@ -707,7 +707,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
25
26 } else {
27
28- if (errno == EINVAL)
29+ if (errno == ENOTTY ||
30+ errno == EINVAL)
31 continue;
32
33 perror ("VIDIOC_QUERYCTRL");
34@@ -774,7 +775,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
35
36 } else {
37
38- if (errno == EINVAL)
39+ if (errno == ENOTTY ||
40+ errno == EINVAL)
41 break;
42
43 perror ("VIDIOC_QUERYCTRL");
44--
452.3.0
46
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend
new file mode 100644
index 00000000..be166965
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI_append_mx6sx = " file://0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch"