summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
authorFabio Estevam <festevam@gmail.com>2024-09-13 22:21:25 -0300
committerFabio Estevam <festevam@gmail.com>2024-09-13 22:25:51 -0300
commitc8fc8ad467fdcde7879bc9bffa73204ffa9a4afd (patch)
treef69792c1f420ee44076d1657f6e8cec2be44cecf /dynamic-layers/openembedded-layer
parent0a63c762a843ee05711842fe13e05a8a2d185d0c (diff)
downloadmeta-freescale-c8fc8ad467fdcde7879bc9bffa73204ffa9a4afd.tar.gz
imx-cst: Remove it now that it is in meta-oe
Since meta-oe commit 87579c932e19 ("imx-cst: Add recipe") the imx-cst recipe is avaiable in meta-oe: https://github.com/openembedded/meta-openembedded/commit/87579c932e19d9802ce05c692b1d56a56d7762fe Remove it from meta-freescale in favor of using the meta-oe version. Signed-off-by: Fabio Estevam <festevam@gmail.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb
deleted file mode 100644
index 0e0ebc6e..00000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "i.MX code signing tool"
2DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library"
3SECTION = "cst"
4LICENSE = "BSD-3-Clause & Apache-2.0"
5
6LIC_FILES_CHKSUM = "\
7 file://LICENSE.bsd3;md5=14aba05f9fa6c25527297c8aac95fcf6 \
8 file://LICENSE.hidapi;md5=e0ea014f523f64f0adb13409055ee59e \
9 file://LICENSE.openssl;md5=3441526b1df5cc01d812c7dfc218cea6 \
10"
11
12DEPENDS = "byacc-native flex-native openssl"
13
14# debian: 3.4.0+dfsg-2
15DEBIAN_PGK_NAME = "imx-code-signing-tool"
16DEBIAN_PGK_VERSION = "${PV}+dfsg"
17
18SRC_URI = "\
19 ${DEBIAN_MIRROR}/main/i/${DEBIAN_PGK_NAME}/${DEBIAN_PGK_NAME}_${DEBIAN_PGK_VERSION}.orig.tar.xz \
20"
21
22SRC_URI[sha256sum] = "52ee3cee3bc500a42095f73c4584e223b4b9d2dfc1cd3e5df965c5952eba8c8d"
23
24S = "${WORKDIR}/${DEBIAN_PGK_NAME}-${DEBIAN_PGK_VERSION}"
25
26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"'
27
28do_compile() {
29 oe_runmake -C code/obj.linux64 OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}"
30 oe_runmake -C add-ons/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
31}
32
33do_install () {
34 install -d ${D}${bindir}
35 install -m 755 ${S}/code/obj.linux64/cst ${D}${bindir}/
36 install -m 755 ${S}/code/obj.linux64/srktool ${D}${bindir}
37 install -m 755 ${S}/add-ons/hab_csf_parser/csf_parser ${D}${bindir}
38}
39
40BBCLASSEXTEND = "native nativesdk"