summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2017-01-25 12:47:10 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-25 14:25:34 -0200
commit44f552cd47c603c3cf97be68fa47e0b9b4e02eb5 (patch)
tree73ef67987dd84aeab3675cead642074a5aede4d6 /dynamic-layers/openembedded-layer
parent67b09d4b6bec8efae566d04b24f67af439349452 (diff)
downloadmeta-freescale-44f552cd47c603c3cf97be68fa47e0b9b4e02eb5.tar.gz
xserver-common: Move to dynamic layers
The xserver-common recipe can only be built if the openbedded (meta-oe) layer is present, so move it to the dynamic layers to prevent breakage if that layer is not in the build. Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common/imx/0016-xserver-common-enable-iglx-module.patch30
-rw-r--r--dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend10
2 files changed, 40 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common/imx/0016-xserver-common-enable-iglx-module.patch b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common/imx/0016-xserver-common-enable-iglx-module.patch
new file mode 100644
index 00000000..283a081b
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common/imx/0016-xserver-common-enable-iglx-module.patch
@@ -0,0 +1,30 @@
1From 8ad045e5e664fe2d1bd9f88616d5bf83437aab4e Mon Sep 17 00:00:00 2001
2From: Yang Dong <b56112@freescale.com>
3Date: Wed, 9 Sep 2015 13:08:57 +0800
4Subject: [PATCH] xserver-common: enable iglx module
5
6Enable iglx module to pass indirect glx rendering test case.
7
8Upstream-Status: Inappropriate [imx specific]
9
10Date: Sep 9, 2015
11Signed-off-by Yang Dong <b56112@freescale.com>
12---
13 X11/xserver-common | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/X11/xserver-common b/X11/xserver-common
17index 4dc48c4..d19b858 100644
18--- a/X11/xserver-common
19+++ b/X11/xserver-common
20@@ -44,6 +44,7 @@ SCREEN_SIZE=`fallback_screen_arg`
21 export USER=root
22 export XSERVER_DEFAULT_ORIENTATION=normal
23
24+INPUT_EXTRA_ARGS="+iglx"
25 ARGS="-br -pn -nolisten tcp $INPUT_EXTRA_ARGS"
26 DPI="100"
27 MOUSE=""
28--
291.9.1
30
diff --git a/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend
new file mode 100644
index 00000000..28d1f7bd
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend
@@ -0,0 +1,10 @@
1# i.MX extra configuration
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4PATCHES_IMX_SPECIFIC = " file://0016-xserver-common-enable-iglx-module.patch \
5"
6SRC_URI_append = " \
7 ${PATCHES_IMX_SPECIFIC} \
8"
9PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}"
10PACKAGE_ARCH_mx7 = "${MACHINE_SOCARCH}"