summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/browser-layer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:21:16 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitca38cdc4de1143cf6b7af76e9426ecf31f0922f0 (patch)
tree01db34465457c4b22036f27dba53d55f01ef6d03 /dynamic-layers/browser-layer
parentb6e2300960729d67720e1e626051999ca7a7009f (diff)
downloadmeta-freescale-ca38cdc4de1143cf6b7af76e9426ecf31f0922f0.tar.gz
Move external layer's specific changes for 'dynamic-layers' subdir
The external layer's specific changes are now in the 'dynamic-layers' subdirectory. This approach ease the identification of layer specific recipes and extensions as all those are more visible isolated of the main layer components. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/browser-layer')
-rw-r--r--dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc49
-rw-r--r--dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend12
2 files changed, 61 insertions, 0 deletions
diff --git a/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
new file mode 100644
index 00000000..f63807d5
--- /dev/null
+++ b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
@@ -0,0 +1,49 @@
1DEPENDS_append_mx6q = " libfslvpuwrap"
2DEPENDS_append_mx6dl = " libfslvpuwrap"
3
4# Additional imx code and patches are included in the chromium-imx git repository.
5# The code below fetches this repository, copies the extra source over to the main
6# chromium source directory, and applies the patches.
7
8CHROMIUM_IMX_BRANCH ?= "master"
9CHROMIUM_IMX_SRCREV ?= "HEAD"
10CHROMIUM_IMX_DESTSUFFIX ?= "chromium-imx-git"
11
12PATCH_BASE_DIR = "${WORKDIR}/${CHROMIUM_IMX_DESTSUFFIX}/patches"
13
14CHROMIUM_IMX_COMMON_PATCHES ?= " "
15CHROMIUM_IMX_VPU_PATCHES ?= " "
16CHROMIUM_IMX_WAYLAND_PATCHES ?= " "
17
18SRC_URI += "git://github.com/Freescale/chromium-imx.git;destsuffix=${CHROMIUM_IMX_DESTSUFFIX};branch=${CHROMIUM_IMX_BRANCH};rev=${CHROMIUM_IMX_SRCREV}"
19
20do_unpack[postfuncs] += "copy_chromium_imx_files"
21# using =+ instead of += to make sure add_chromium_imx_patches is
22# executed before add_ozone_wayland_patches in the main recipe;
23# this is necessary because add_chromium_imx_patches appends
24# patches to the OZONE_WAYLAND_EXTRA_PATCHES variable
25do_patch[prefuncs] =+ "add_chromium_imx_patches"
26
27# * Lost context problems are not known to happen with Vivante GPUs,
28# so it is safe to use ignore-lost-context
29# * EGL is on by default due to the GPU on the i.MX6
30PACKAGECONFIG_append = " use-egl ignore-lost-context"
31
32copy_chromium_imx_files() {
33 # sources in src/ are already organized in a manner
34 # that matches the subdirectories in the chromium
35 # source directory; just copy over the files in src/
36 cp -r ${WORKDIR}/chromium-imx-git/src/* ${S}/
37}
38
39python add_chromium_imx_patches() {
40 d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_COMMON_PATCHES', 1))
41 d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_VPU_PATCHES', 1))
42 d.appendVar('OZONE_WAYLAND_EXTRA_PATCHES', ' ' + d.getVar('CHROMIUM_IMX_WAYLAND_PATCHES', 1))
43}
44
45# Necessary flags to enable support for h.264 and MP4 in Chromium
46# (Parsing is done by ffmpeg)
47EXTRA_OEGYP += "-Dproprietary_codecs=1 -Dffmpeg_branding=Chrome"
48
49COMPATIBLE_MACHINE = "(mx6)"
diff --git a/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend
new file mode 100644
index 00000000..d9c5d154
--- /dev/null
+++ b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend
@@ -0,0 +1,12 @@
1include chromium-imx.inc
2
3CHROMIUM_IMX_BRANCH = "chromium-40"
4CHROMIUM_IMX_SRCREV = "af13a3dbdfdb4b162a9f9692761216e5d6204e57"
5CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch"
6
7VPU_PATCHES = "file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-GPU-.patch"
8
9CHROMIUM_IMX_VPU_PATCHES_mx6q += "${VPU_PATCHES}"
10CHROMIUM_IMX_VPU_PATCHES_mx6dl += "${VPU_PATCHES}"
11
12CHROMIUM_IMX_WAYLAND_PATCHES += "file://${PATCH_BASE_DIR}/wayland/0001-Modify-eglwayland-versions-for-Vivante-GPUs.patch"