summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-08-24 18:35:20 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2021-08-24 18:35:20 -0500
commitfab06649d13b1543fccf29fa5f7c18a7f11a0ea6 (patch)
treeaaeee0b091c68592fab9609584da079ac127b864 /conf
parent5c198573eda7afe9356e630e83aef875f7a5fa7a (diff)
downloadmeta-freescale-fab06649d13b1543fccf29fa5f7c18a7f11a0ea6.tar.gz
imx-base.inc: Define a default value for OPTEE_BIN_EXT
Without a default the IMAGE_BOOT_FILES is not parsed properly, leading to the following error for machines without such a variable definition: ``` | ERROR: _exec_cmd: install -m 0644 -D /z/build-master/imx233-olinuxino-maxi/build/tmp-glibc/deploy/images/imx233-olinuxino-maxi/make_dtb_boot_files /z/build-master/imx233-olinuxino-maxi/build/tmp-glibc/work/imx233_olinuxino_maxi-oe-linux-gnueabi/core-image-base/1.0-r0/tmp-wic/boot.2/make_dtb_boot_files returned '1' instead of 0 | output: install: cannot stat '/z/build-master/imx233-olinuxino-maxi/build/tmp-glibc/deploy/images/imx233-olinuxino-maxi/make_dtb_boot_files': No such file or directory ERROR: Task (/opt/oe/configs/z/build-master/imx233-olinuxino-maxi/layers/openembedded-core/meta/recipes-core/images/core-image-base.bb:do_image_wic) failed with exit code '1' ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/machine/include/imx-base.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index e8605749..99c4f9f7 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -406,6 +406,7 @@ SOC_DEFAULT_IMAGE_FSTYPES:mxs = "uboot-mxsboot-sdcard wic.bmap wic.gz"
406# Do not update fstab file when using wic images 406# Do not update fstab file when using wic images
407WIC_CREATE_EXTRA_ARGS ?= "--no-fstab-update" 407WIC_CREATE_EXTRA_ARGS ?= "--no-fstab-update"
408 408
409OPTEE_BIN_EXT ??= ""
409OPTEE_BOOT_IMAGE = "tee.bin uTee-${OPTEE_BIN_EXT}" 410OPTEE_BOOT_IMAGE = "tee.bin uTee-${OPTEE_BIN_EXT}"
410OPTEE_BOOT_IMAGE:aarch64 = "tee.bin" 411OPTEE_BOOT_IMAGE:aarch64 = "tee.bin"
411 412