summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-31 17:39:35 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-03-31 19:37:58 -0500
commitd93b387a8740bc5f6e61dac13888e9cc0f1cefa2 (patch)
tree5111741914b7fcb87aac225fa886c757e782456b /classes
parent65398605b9f412ac851c945f4cbe36a81b899a8f (diff)
downloadmeta-freescale-d93b387a8740bc5f6e61dac13888e9cc0f1cefa2.tar.gz
mx8dx: Normalize MACHINEOVERRIDES implementation
The imx8dx-mek machine is similar to imx8qxp-mek and so the mx8qxp override was included in the MACHINEOVERRIDES hierarchy. This is non-standard, and the rework of the SOC overrides didn't handle it properly, leading to a build break: ``` Log data follows: | DEBUG: Executing shell function do_compile | NOTE: 8QX boot binary build | cp: failed to access '/home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin': Not a directory | WARNING: /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636:179 exit 1 from 'cp /home/aquino/src/ossystems/oel-platform/build/tmp/deploy/images/imx8dx-mek/imx-boot$ tools/scfw_tcm.bin /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin' | WARNING: Backtrace (BB generated script): | #1: compile_mx8x, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 179 | #2: do_compile, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 151 | #3: main, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 189 ERROR: Task (/home/aquino/src/ossystems/oel-platform/sources/meta-freescale/recipes-bsp/imx-mkimage/imx-boot_1.0.bb:do_compile) failed with exit code '1' ``` Fix the problem by removing mx8qxp from the mx8dx hierarchy and adapting existing mx8qxp overrides appropriately. Fixes: #1027 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/use-imx-security-controller-firmware.bbclass10
1 files changed, 5 insertions, 5 deletions
diff --git a/classes/use-imx-security-controller-firmware.bbclass b/classes/use-imx-security-controller-firmware.bbclass
index bdbf3684..dfd708e4 100644
--- a/classes/use-imx-security-controller-firmware.bbclass
+++ b/classes/use-imx-security-controller-firmware.bbclass
@@ -16,13 +16,13 @@
16# This behavior ensures that derivatives which requires SECO Firmware to be 16# This behavior ensures that derivatives which requires SECO Firmware to be
17# present in the image file have it properly defined. 17# present in the image file have it properly defined.
18 18
19SECO_FIRMWARE_NAME ?= "" 19SECO_FIRMWARE_NAME ?= ""
20 20SECO_FIRMWARE_NAME:mx8qm-nxp-bsp = "mx8qmb0-ahab-container.img"
21SECO_FIRMWARE_NAME:mx8qm-nxp-bsp = "mx8qmb0-ahab-container.img" 21SECO_FIRMWARE_NAME:mx8qxp-nxp-bsp = \
22SECO_FIRMWARE_NAME:mx8qxp-nxp-bsp = \
23 "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'mx8qxb0-ahab-container.img', \ 22 "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'mx8qxb0-ahab-container.img', \
24 'mx8qxc0-ahab-container.img', d)}" 23 'mx8qxc0-ahab-container.img', d)}"
25SECO_FIRMWARE_NAME:mx8dxl-nxp-bsp = "mx8dxla1-ahab-container.img" 24SECO_FIRMWARE_NAME:mx8dx-nxp-bsp = "mx8qxc0-ahab-container.img"
25SECO_FIRMWARE_NAME:mx8dxl-nxp-bsp = "mx8dxla1-ahab-container.img"
26 26
27python () { 27python () {
28 if "mx8m-nxp-bsp" in d.getVar('MACHINEOVERRIDES').split(":"): 28 if "mx8m-nxp-bsp" in d.getVar('MACHINEOVERRIDES').split(":"):