summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-03-29 19:07:53 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-03-30 09:21:18 -0300
commitf75ec4ec1e25afc2f415e6cf25b96d2caf8f3936 (patch)
tree1131cd64ff999529bb78aa2832487e45445f41b2
parent74eb1e5b9ca95c5c60136553fbc33c497490807a (diff)
downloadmeta-freescale-f75ec4ec1e25afc2f415e6cf25b96d2caf8f3936.tar.gz
imx-gpu-apitrace: x11: make python3 compatible
When building for fslc-x11 python code generation still fails, e.g.: | File ".../imx-gpu-apitrace/7.1.0-r0/git/wrappers/glxtrace.py", line 70 | print ' if(_glXGetCurrentDisplay == &glXGetCurrentDisplay ){' Convert python2 print statements to python3. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0005-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch60
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb1
2 files changed, 61 insertions, 0 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0005-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0005-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch
new file mode 100644
index 00000000..6bff7e92
--- /dev/null
+++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0005-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch
@@ -0,0 +1,60 @@
1From 8b3afcaeebdd87962f2f3fef36973090621d116b Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Sun, 29 Mar 2020 15:38:31 +0000
4Subject: [PATCH 5/5] scripts: Tie a few more Python 2 to 3 conversion loose
5 ends.
6
7Upstream-Status: pending
8Note: code exists in NXP's fork only.
9
10Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
11---
12 wrappers/glxtrace.py | 14 +++++++-------
13 1 file changed, 7 insertions(+), 7 deletions(-)
14
15diff --git a/wrappers/glxtrace.py b/wrappers/glxtrace.py
16index b05028e2..2472560d 100644
17--- a/wrappers/glxtrace.py
18+++ b/wrappers/glxtrace.py
19@@ -67,9 +67,9 @@ class GlxTracer(GlTracer):
20 print(' gltrace::releaseContext((uintptr_t)ctx);')
21
22 if function.name == 'glXGetCurrentDisplay':
23- print ' if(_glXGetCurrentDisplay == &glXGetCurrentDisplay ){'
24- print ' _glXGetCurrentDisplay = (PFN_GLXGETCURRENTDISPLAY)_getPublicProcAddress("glXGetCurrentDisplay");'
25- print ' }'
26+ print (' if(_glXGetCurrentDisplay == &glXGetCurrentDisplay ){')
27+ print (' _glXGetCurrentDisplay = (PFN_GLXGETCURRENTDISPLAY)_getPublicProcAddress("glXGetCurrentDisplay");')
28+ print (' }')
29
30 GlTracer.traceFunctionImplBody(self, function)
31
32@@ -184,7 +184,7 @@ if __name__ == '__main__':
33 tracer = GlxTracer()
34 tracer.traceApi(api)
35
36- print r'''
37+ print (r'''
38
39
40 /*
41@@ -247,8 +247,8 @@ void * dlopen(const char *filename, int flag)
42
43
44
45-'''
46- print r'''
47+''')
48+ print (r'''
49 /*
50 * let the GPU driver know that we are in apitrace
51 */
52@@ -257,4 +257,4 @@ int APIENTRY ApiTraceEnabled(void) {
53 return 1;
54 }
55
56-'''
57+''')
58--
592.20.1
60
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb
index 0169c26f..180db8d8 100644
--- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb
+++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb
@@ -10,6 +10,7 @@ SRC_URI = "\
10 file://0002-specs-Tie-Python-2-3-conversion-loose-ends.patch \ 10 file://0002-specs-Tie-Python-2-3-conversion-loose-ends.patch \
11 file://0003-scripts-Tie-Python-2-3-conversion-loose-ends.patch \ 11 file://0003-scripts-Tie-Python-2-3-conversion-loose-ends.patch \
12 file://0004-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch \ 12 file://0004-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch \
13 file://0005-scripts-Tie-a-few-more-Python-2-to-3-conversion-loos.patch \
13" 14"
14SRCREV = "09579e67262af9c993dd082055a924c2c61cf34d" 15SRCREV = "09579e67262af9c993dd082055a924c2c61cf34d"
15 16