summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-09-02 17:10:32 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:18 -0300
commitefa3c73dd97c62ed2a4e6cf56db7f9dc7f349a37 (patch)
tree418833382154e2e1809d2e8dee540ce40362f30f
parentebe3bb62f466b6dc390d9cc063a589ce6cf16d94 (diff)
downloadmeta-freescale-efa3c73dd97c62ed2a4e6cf56db7f9dc7f349a37.tar.gz
ipc-ust: move SOC specific variables to qoriq-base.inc
* Add IPC_UST_SOC variables in qoriq-base.inc to define SOC type for ipc-ust * Use IPC_UST_SOC in ipc-ust bb file Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/machine/include/qoriq-base.inc4
-rw-r--r--recipes-extended/ipc-ust/ipc-ust_git.bb11
2 files changed, 10 insertions, 5 deletions
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc
index 1b49cc42..f85f18e1 100644
--- a/conf/machine/include/qoriq-base.inc
+++ b/conf/machine/include/qoriq-base.inc
@@ -20,4 +20,8 @@ MACHINE_EXTRA_RRECOMMENDS ?= "udev-rules-qoriq"
20 20
21EXTRA_IMAGEDEPENDS += "u-boot cst-native" 21EXTRA_IMAGEDEPENDS += "u-boot cst-native"
22 22
23IPC_UST_SOC_bsc9131 = "B913x"
24IPC_UST_SOC_bsc9132 = "B913x"
25IPC_UST_SOC_b4 = "B4860"
26
23MACHINEOVERRIDES .= ":qoriq" 27MACHINEOVERRIDES .= ":qoriq"
diff --git a/recipes-extended/ipc-ust/ipc-ust_git.bb b/recipes-extended/ipc-ust/ipc-ust_git.bb
index 5ba3411f..c39716b4 100644
--- a/recipes-extended/ipc-ust/ipc-ust_git.bb
+++ b/recipes-extended/ipc-ust/ipc-ust_git.bb
@@ -5,6 +5,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5 5
6require ipc.inc 6require ipc.inc
7 7
8python () {
9 if not d.getVar("IPC_UST_SOC", True):
10 raise bb.parse.SkipPackage("IPC_UST_SOC is not defined in qoriq-base.inc")
11}
12
8S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
9 14
10# workaround for issue of parallel build, required a actual fix in ipc source 15# workaround for issue of parallel build, required a actual fix in ipc source
@@ -13,11 +18,7 @@ PARALLEL_MAKE = ""
13EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC}" AR="${AR}"' 18EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC}" AR="${AR}"'
14 19
15do_compile () { 20do_compile () {
16 case ${MACHINE} in 21 oe_runmake ${IPC_UST_SOC}=1
17 bsc9132qds|bsc9131rdb) SOC=B913x;;
18 b4860qds|b4420qds|b4860qds-64b) SOC=B4860;;
19 esac
20 oe_runmake ${SOC}=1
21} 22}
22 23
23do_install () { 24do_install () {