summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-07-26 13:09:20 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-12-13 07:26:04 -0200
commiteb2b9bf4cefa47175e76eaa50d4a58b5117bdc72 (patch)
treeb63eb5d5afe6ce0f81a4d97521e90dc8ebd3b97b
parent1e34a9f93fe9c78652d6ca665e330facd7df4264 (diff)
downloadmeta-freescale-eb2b9bf4cefa47175e76eaa50d4a58b5117bdc72.tar.gz
u-boot-imx: Deploy boot image generation tools for i.MX 8M
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2017.03.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
index f80aa592..705ff164 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb
@@ -20,5 +20,29 @@ inherit dtc-145 fsl-u-boot-localversion
20 20
21LOCALVERSION ?= "-${SRCBRANCH}" 21LOCALVERSION ?= "-${SRCBRANCH}"
22 22
23BOOT_TOOLS = "imx-boot-tools"
24
25do_deploy_append_mx8m() {
26 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
27 if [ -n "${UBOOT_CONFIG}" ]
28 then
29 for config in ${UBOOT_MACHINE}; do
30 i=$(expr $i + 1);
31 for type in ${UBOOT_CONFIG}; do
32 j=$(expr $j + 1);
33 if [ $j -eq $i ]
34 then
35 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
36 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
37 install -m 0777 ${B}/${config}/tools/mkimage ${DEPLOYDIR}/${BOOT_TOOLS}/mkimage_uboot
38 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
39 fi
40 done
41 unset j
42 done
43 unset i
44 fi
45}
46
23PACKAGE_ARCH = "${MACHINE_ARCH}" 47PACKAGE_ARCH = "${MACHINE_ARCH}"
24COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 48COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"