summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihai Lindner <mihai.lindner@nxp.com>2019-05-14 15:43:25 +0300
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-02 15:52:20 -0300
commitea77742e7c456222263cc5ff2af4500cfc4ba9e7 (patch)
treeb5498db34e6b34504885429fd0927775a8f7fdaf
parentd15639a0a27393aa455adae113f4692c27367e89 (diff)
downloadmeta-freescale-ea77742e7c456222263cc5ff2af4500cfc4ba9e7.tar.gz
dtc-145: Remove class and recipe
These were used as workaround for issues with building u-boot 2017.03 and older, after dtc upgrade to 1.4.6 and newer. We can drop them after upgrading all providers of u-boot. Signed-off-by: Mihai Lindner <mihai.lindner@nxp.com>
-rw-r--r--classes/dtc-145.bbclass7
-rw-r--r--recipes-kernel/dtc/dtc-145_git.bb20
-rw-r--r--recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch55
-rw-r--r--recipes-kernel/dtc/files/make_install.patch17
4 files changed, 0 insertions, 99 deletions
diff --git a/classes/dtc-145.bbclass b/classes/dtc-145.bbclass
deleted file mode 100644
index d4a30711..00000000
--- a/classes/dtc-145.bbclass
+++ /dev/null
@@ -1,7 +0,0 @@
1# Use this class for U-Boot 2017.03 or older.
2
3DEPENDS_append = " dtc-145-native"
4
5do_configure_prepend () {
6 sed -i -e 's/^DTC[[:space:]]*=[[:space:]]*dtc[[:space:]]*$/DTC = dtc-145/' ${S}/Makefile
7}
diff --git a/recipes-kernel/dtc/dtc-145_git.bb b/recipes-kernel/dtc/dtc-145_git.bb
deleted file mode 100644
index 2d4097bb..00000000
--- a/recipes-kernel/dtc/dtc-145_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1require recipes-kernel/dtc/dtc.inc
2
3LIC_FILES_CHKSUM = " \
4 file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
5 file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c \
6"
7
8SRCREV = "22a65c5331c22979d416738eb756b9541672e00d"
9
10SRC_URI += "file://0001-Fix-compiler-warnings-seen-with-musl.patch \
11 "
12S = "${WORKDIR}/git"
13
14# only install the dtc binary renamed to dtc-145
15do_install () {
16 install -d ${D}/${bindir}
17 install -m 755 dtc ${D}/${bindir}/dtc-145
18}
19
20BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch b/recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch
deleted file mode 100644
index 418a6498..00000000
--- a/recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From 50034ca2600ae07203f397af6d78e2e9ff16bc02 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Oct 2018 18:12:23 -0700
4Subject: [PATCH] Fix compiler warnings seen with musl
5
6Fixes
7
8checks.c:975:16: error: format '%ld' expects argument of type 'long
9int', but argument 6 has type 'unsigned int' [-Werror=format=]
10 FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple
11of %ld in node %s",
12 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
13 prop->name, prop->val.len, sizeof(cell_t), node->fullpath);
14 ~~~~~~~~~~~~~~
15checks.c:96:23: note: in definition of macro 'FAIL'
16 check_msg((c), dti, __VA_ARGS__); \
17 ^~~~~~~~~~~
18checks.c: In function 'check_interrupts_property':
19checks.c:1166:16: error: format '%ld' expects argument of type 'long
20int', but argument 6 has type 'unsigned int' [-Werror=format=]
21 FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple
22of %ld in node %s",
23 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
24 irq_prop->name, irq_prop->val.len, sizeof(cell_t),
25 ~~~~~~~~~~~~~~
26
27Upstream-Status: Backport [adapted from an upstream fix]
28
29Signed-off-by: Khem Raj <raj.khem@gmail.com>
30---
31 checks.c | 4 ++--
32 1 file changed, 2 insertions(+), 2 deletions(-)
33
34diff --git a/checks.c b/checks.c
35index 902f2e3..08a3a29 100644
36--- a/checks.c
37+++ b/checks.c
38@@ -972,7 +972,7 @@ static void check_property_phandle_args(struct check *c,
39 int cell, cellsize = 0;
40
41 if (prop->val.len % sizeof(cell_t)) {
42- FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s",
43+ FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s",
44 prop->name, prop->val.len, sizeof(cell_t), node->fullpath);
45 return;
46 }
47@@ -1163,7 +1163,7 @@ static void check_interrupts_property(struct check *c,
48 return;
49
50 if (irq_prop->val.len % sizeof(cell_t))
51- FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s",
52+ FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s",
53 irq_prop->name, irq_prop->val.len, sizeof(cell_t),
54 node->fullpath);
55
diff --git a/recipes-kernel/dtc/files/make_install.patch b/recipes-kernel/dtc/files/make_install.patch
deleted file mode 100644
index ccf17b38..00000000
--- a/recipes-kernel/dtc/files/make_install.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1Upstream-Status: Inappropriate [configuration]
2
3Index: git/Makefile
4===================================================================
5--- git.orig/Makefile
6+++ git/Makefile
7@@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS)
8 install-lib: all
9 @$(VECHO) INSTALL-LIB
10 $(INSTALL) -d $(DESTDIR)$(LIBDIR)
11- $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
12- ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
13+ $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
14+ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
15 ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
16 $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
17