summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJun Zhu <junzhu@nxp.com>2017-10-13 00:15:45 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-16 14:27:29 -0200
commite2de0908b1d88e3bd60cb11d25b70cf92fe2f089 (patch)
tree1abfe7e23819f9140a1fa35638286125fe8bcd7f
parent20155a5ccef3f5ac20deb010a290d612f6246771 (diff)
downloadmeta-freescale-e2de0908b1d88e3bd60cb11d25b70cf92fe2f089.tar.gz
imx-test: Add git recipe
- As imx-test git repository is public as git://git.freescale.com/imx/imx-test.git, build it from git. - Add support to i.MX 6SLL and 7ULP. - Replace imx-vpu with virtual/imxvpu in DEPNEDS. - Set PV as 6.0+${SRCPV} Signed-off-by: Jun Zhu <junzhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-test/imx-test.inc14
-rw-r--r--recipes-bsp/imx-test/imx-test_5.7.bb8
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb16
3 files changed, 25 insertions, 13 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index ce24860d..63eb83d5 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -1,23 +1,25 @@
1# Copyright (C) 2012-2016 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
2# Copyright (C) 2015 Freescale Semiconductor 2# Copyright (C) 2015 Freescale Semiconductor
3# Copyright 2017 NXP
3 4
4SUMMARY = "Test programs for IMX BSP" 5SUMMARY = "Test programs for IMX BSP"
5DESCRIPTION = "Unit tests for the IMX BSP" 6DESCRIPTION = "Unit tests for the IMX BSP"
6SECTION = "base" 7SECTION = "base"
7DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu" 8
8DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu" 9DEPENDS_mx6q = "virtual/kernel imx-lib virtual/imxvpu"
10DEPENDS_mx6dl = "virtual/kernel imx-lib virtual/imxvpu"
9DEPENDS_mx6sl = "virtual/kernel imx-lib" 11DEPENDS_mx6sl = "virtual/kernel imx-lib"
12DEPENDS_mx6sll = "virtual/kernel imx-lib"
10DEPENDS_mx6sx = "virtual/kernel imx-lib" 13DEPENDS_mx6sx = "virtual/kernel imx-lib"
11DEPENDS_mx6ul = "virtual/kernel imx-lib" 14DEPENDS_mx6ul = "virtual/kernel imx-lib"
12DEPENDS_mx7d = "virtual/kernel imx-lib" 15DEPENDS_mx7d = "virtual/kernel imx-lib"
16DEPENDS_mx7ulp = "virtual/kernel imx-lib"
13 17
14LICENSE = "GPLv2" 18LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 19LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
16 20
17PE = "1" 21PE = "1"
18 22
19SRC_URI = "${FSL_MIRROR}/imx-test-${PV}.tar.gz"
20
21inherit module-base 23inherit module-base
22 24
23INHIBIT_PACKAGE_STRIP = "1" 25INHIBIT_PACKAGE_STRIP = "1"
@@ -26,9 +28,11 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
26PLATFORM_mx6q = "IMX6Q" 28PLATFORM_mx6q = "IMX6Q"
27PLATFORM_mx6dl = "IMX6Q" 29PLATFORM_mx6dl = "IMX6Q"
28PLATFORM_mx6sl = "IMX6SL" 30PLATFORM_mx6sl = "IMX6SL"
31PLATFORM_mx6sll = "IMX6SL"
29PLATFORM_mx6sx = "IMX6SX" 32PLATFORM_mx6sx = "IMX6SX"
30PLATFORM_mx7d = "IMX7D"
31PLATFORM_mx6ul = "IMX6UL" 33PLATFORM_mx6ul = "IMX6UL"
34PLATFORM_mx7d = "IMX7D"
35PLATFORM_mx7ulp = "IMX7D"
32 36
33PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" 37PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
34PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" 38PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
diff --git a/recipes-bsp/imx-test/imx-test_5.7.bb b/recipes-bsp/imx-test/imx-test_5.7.bb
deleted file mode 100644
index 766598fb..00000000
--- a/recipes-bsp/imx-test/imx-test_5.7.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2
3include imx-test.inc
4
5SRC_URI[md5sum] = "bf55f7c2c9fd6664d640557f7cd107a1"
6SRC_URI[sha256sum] = "d7a503112098befc91c4d256d8683ca11eb4246123f4e57cf2df498791294888"
7
8COMPATIBLE_MACHINE = "(mx6|mx7)"
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
new file mode 100644
index 00000000..4a2472b3
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -0,0 +1,16 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2017 NXP
3
4include imx-test.inc
5
6PV = "6.0+${SRCPV}"
7
8PARALLEL_MAKE="-j 1"
9
10SRCBRANCH = "imx_4.9.11_1.0.0_ga"
11SRC_URI = "git://git.freescale.com/imx/imx-test.git;protocol=git;branch=${SRCBRANCH}"
12SRCREV = "fb250a795ce0d25c19610e9e19e1cd815fc64cb9"
13
14S = "${WORKDIR}/git"
15
16COMPATIBLE_MACHINE = "(mx6|mx7)"