diff options
author | Hiago De Franco <hiago.franco@toradex.com> | 2025-02-18 11:18:37 -0300 |
---|---|---|
committer | Hiago De Franco <hiago.franco@toradex.com> | 2025-02-18 13:17:10 -0300 |
commit | deebc27a3abb88964a05aea794ffd9e86e0fd0bb (patch) | |
tree | a1144cf1e58d3afb9343723bff743210ef1ab977 | |
parent | d366bc4436cb07dcb426ffb0ab648e158d56dd75 (diff) | |
download | meta-freescale-deebc27a3abb88964a05aea794ffd9e86e0fd0bb.tar.gz |
firmware-nxp-wifi: create symbolic links to firmware/mrvl folder
The upstream kernel Wi-Fi driver expects the sdiouart8997_combo_v4 and
sdiouartiw416_combo_v0 binaries to be located under firmware/mrvl [1],
different from the out-of-tree driver, which places them under
firmware/nxp. Create symbolic links to deploy these binaries in the
correct location for the upstream driver.
Due to this change, bump the recipe version to 1.1.
[1] https://github.com/torvalds/linux/blob/master/drivers/net/wireless/marvell/mwifiex/sdio.h#L31
Signed-off-by: Hiago De Franco <hiago.franco@toradex.com>
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-nxp-wifi_1.1.bb (renamed from recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb) | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb b/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.1.bb index b362c4e2..51184b88 100644 --- a/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb +++ b/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.1.bb | |||
@@ -44,7 +44,10 @@ do_install() { | |||
44 | 44 | ||
45 | oe_runmake install INSTALLDIR=${D}${nonarch_base_libdir}/firmware/nxp | 45 | oe_runmake install INSTALLDIR=${D}${nonarch_base_libdir}/firmware/nxp |
46 | 46 | ||
47 | 47 | # Upstream SDIO8997 and IW416 driver firmwares are located on mrvl folder | |
48 | install -d ${D}${nonarch_base_libdir}/firmware/mrvl | ||
49 | ln -frs ${D}${nonarch_base_libdir}/firmware/nxp/sdiouart8997_combo_v4.bin ${D}${nonarch_base_libdir}/firmware/mrvl/sdiouart8997_combo_v4.bin | ||
50 | ln -frs ${D}${nonarch_base_libdir}/firmware/nxp/sdiouartiw416_combo_v0.bin ${D}${nonarch_base_libdir}/firmware/mrvl/sdiouartiw416_combo_v0.bin | ||
48 | } | 51 | } |
49 | 52 | ||
50 | PACKAGES =+ " \ | 53 | PACKAGES =+ " \ |
@@ -105,6 +108,7 @@ RREPLACES:${PN}-nxp8997-pcie = "linux-firmware-nxp8997-pcie" | |||
105 | RCONFLICTS:${PN}-nxp8997-pcie = "linux-firmware-nxp8997-pcie" | 108 | RCONFLICTS:${PN}-nxp8997-pcie = "linux-firmware-nxp8997-pcie" |
106 | 109 | ||
107 | FILES:${PN}-nxp8997-sdio = " \ | 110 | FILES:${PN}-nxp8997-sdio = " \ |
111 | ${nonarch_base_libdir}/firmware/mrvl/sdiouart8997_combo_v4.bin \ | ||
108 | ${nonarch_base_libdir}/firmware/nxp/sdio*8997* \ | 112 | ${nonarch_base_libdir}/firmware/nxp/sdio*8997* \ |
109 | " | 113 | " |
110 | RDEPENDS:${PN}-nxp8997-sdio += "${PN}-nxp8997-common" | 114 | RDEPENDS:${PN}-nxp8997-sdio += "${PN}-nxp8997-common" |
@@ -139,6 +143,7 @@ RREPLACES:${PN}-nxp9098-sdio = "linux-firmware-nxp9098-sdio" | |||
139 | RCONFLICTS:${PN}-nxp9098-sdio = "linux-firmware-nxp9098-sdio" | 143 | RCONFLICTS:${PN}-nxp9098-sdio = "linux-firmware-nxp9098-sdio" |
140 | 144 | ||
141 | FILES:${PN}-nxpiw416-sdio = " \ | 145 | FILES:${PN}-nxpiw416-sdio = " \ |
146 | ${nonarch_base_libdir}/firmware/mrvl/sdiouartiw416_combo_v0.bin \ | ||
142 | ${nonarch_base_libdir}/firmware/nxp/*iw416* \ | 147 | ${nonarch_base_libdir}/firmware/nxp/*iw416* \ |
143 | " | 148 | " |
144 | RDEPENDS:${PN}-nxpiw416-sdio += "${PN}-nxp-common" | 149 | RDEPENDS:${PN}-nxpiw416-sdio += "${PN}-nxp-common" |