summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Rehsack <sno@NetBSD.org>2020-02-10 15:52:04 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-02-11 18:25:22 -0300
commitd949a7720da1ee2d8ca056a1ca586a0cf14c8e07 (patch)
treeb39b42e1c3d5765772a9863c64b73208067d3352
parent069a29886eefd7adb7d79f8e8be80d6a89608843 (diff)
downloadmeta-freescale-d949a7720da1ee2d8ca056a1ca586a0cf14c8e07.tar.gz
management-complex: add LSDK-19.03's v10.14.1
For not clearly discovered reason, ls2088ardb development board doesn't boot with v10.18.0 neither with 10.20.1. Add 10.14.1 from LSDK 19.03 to have a booting 208x. Signed-off-by: Jens Rehsack <sno@NetBSD.org>
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.14.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
new file mode 100644
index 00000000..52da410e
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
@@ -0,0 +1,41 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1"
10SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc"
11
12S = "${WORKDIR}/git"
13
14REGLEX_ls2088a = "ls2088a"
15REGLEX_ls2080a = "ls2080a"
16REGLEX_ls1088a = "ls1088a"
17REGLEX_lx2160a = "lx2160a"
18
19do_install () {
20 install -d ${D}/boot
21 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
22}
23
24do_deploy () {
25 install -d ${DEPLOYDIR}/mc_app
26 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
27 # make a symlink to the latest binary
28 for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
29 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
30 done
31}
32addtask deploy before do_build after do_install
33
34PACKAGES += "${PN}-image"
35FILES_${PN}-image += "/boot"
36
37INHIBIT_PACKAGE_STRIP = "1"
38
39COMPATIBLE_MACHINE = "(qoriq-arm64)"
40PACKAGE_ARCH = "${MACHINE_ARCH}"
41