summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-03 15:54:10 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-03 15:54:10 -0700
commitd942acf911f2577e081e74cf0f7578ca5221d579 (patch)
tree1b596f55d732ce86750fd014eef5d167392e1995
parent84b9ae5d0859cb6920056a1f9295917bad83383a (diff)
downloadmeta-freescale-d942acf911f2577e081e74cf0f7578ca5221d579.tar.gz
imx-atf: Use clang when using toolchain-clang defaults
When clang is default compiler, we need to ensure that its added as dependency as well. Reported-by: Cliff Brake <cbrake@bec-systems.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index 3f627150..d6e02a71 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -40,6 +40,9 @@ LD[unexport] = "1"
40INHIBIT_DEFAULT_DEPS = "1" 40INHIBIT_DEFAULT_DEPS = "1"
41DEPENDS = "virtual/${HOST_PREFIX}gcc" 41DEPENDS = "virtual/${HOST_PREFIX}gcc"
42 42
43# Bring in clang compiler if using clang as default
44DEPENDS:append:toolchain-clang = " clang-cross-${TARGET_ARCH}"
45
43BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 46BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
44 47
45# CC and LD introduce arguments which conflict with those otherwise provided by 48# CC and LD introduce arguments which conflict with those otherwise provided by