summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-06-01 15:23:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-06-01 15:43:58 +0200
commitd6c982648868009ea38b36e1eabadef94742b3ca (patch)
treef4fa191d85560569f17974a95f17e231af7eb646
parenta7a573a216d5a1ee3ac0349c886d454773a36627 (diff)
downloadmeta-freescale-d6c982648868009ea38b36e1eabadef94742b3ca.tar.gz
gstreamer1.0-plugins-good_1.22.5.imx: fix compile time error
GCC-14 set more warnings to errors, demote implicit-function-declaration and implicit-function-declaration to a warning. Fixes: .../v4l2/gstv4l2videoenc.c:782:9: error: implicit declaration of function 'gst_is_dmabuf_memory'; did you mean 'gst_is_v4l2_memory'? [-Wimplicit-function-declaration] .../sys/v4l2/gstv4l2videodec.c:1185:30: error: initialization of 'GstVideoFrame *' {aka 'struct _GstVideoFrame *'} from incompatible pointer type 'GstVideoCodecFrame *' {aka 'struct _GstVideoCodecFrame *'} [-Wincompatible-pointer-types] .../sys/v4l2/gstv4l2videodec.c:1187:48: error: passing argument 2 of 'gst_video_decoder_drop_frame' from incompatible pointer type [-Wincompatible-pointer-types] .../sys/v4l2/gstv4l2videodec.c:1232:30: error: initialization of 'GstVideoFrame *' {aka 'struct _GstVideoFrame *'} from incompatible pointer type 'GstVideoCodecFrame *' {aka 'struct _GstVideoCodecFrame *'} [-Wincompatible-pointer-types] .../sys/v4l2/gstv4l2videodec.c:1234:48: error: passing argument 2 of 'gst_video_decoder_drop_frame' from incompatible pointer type [-Wincompatible-pointer-types] Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.imx.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.imx.bb
index 9e09ef93..1234f3ad 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.5.imx.bb
@@ -120,6 +120,11 @@ GLIBC_64BIT_TIME_FLAGS:mx7-nxp-bsp = ""
120INSANE_SKIP:mx6-nxp-bsp:append = " 32bit-time" 120INSANE_SKIP:mx6-nxp-bsp:append = " 32bit-time"
121INSANE_SKIP:mx7-nxp-bsp:append = " 32bit-time" 121INSANE_SKIP:mx7-nxp-bsp:append = " 32bit-time"
122 122
123# GCC-14 otherwise errors out
124CFLAGS += " \
125 -Wno-error=implicit-function-declaration \
126 -Wno-error=incompatible-pointer-types \
127"
123S = "${WORKDIR}/git" 128S = "${WORKDIR}/git"
124 129
125COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 130COMPATIBLE_MACHINE = "(imx-nxp-bsp)"