summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-02-26 14:14:07 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-03-03 18:26:17 -0300
commitcb3f6b356b4b0d4a36e57a280b582cc2cacea326 (patch)
tree434c37cecd2c7a8da1a1f6a99dcff64bcefd72ac
parent3da0f1b64dae97bab201872c26c6bb81e22628da (diff)
downloadmeta-freescale-cb3f6b356b4b0d4a36e57a280b582cc2cacea326.tar.gz
gstreamer1.0-rtsp-server: Transition to meson based builds
Following modifications were performed: - Remove reference to autotools/M4 related patch: [0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch] - Drop reference to gettext handling - Remove all autotooling class references and functions and replace them with meson class - Add patch to fix GIR support in the meson.build file Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch36
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.0.bb20
2 files changed, 45 insertions, 11 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch
new file mode 100644
index 00000000..6962a50d
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch
@@ -0,0 +1,36 @@
1From 95ce953e34cd0e9f5d42ce7900a9572e7bc8ca47 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
3Date: Fri, 18 Oct 2019 00:42:12 +0100
4Subject: [PATCH] meson: build gir even when cross-compiling if introspection
5 was enabled explicitly
6
7This can be made to work in certain circumstances when
8cross-compiling, so default to not building g-i stuff
9when cross-compiling, but allow it if introspection was
10enabled explicitly via -Dintrospection=enabled.
11
12See gstreamer/gstreamer#454 and gstreamer/gstreamer#381.
13
14Upstream-Status: Backport [95ce953e34cd0e9f5d42ce7900a9572e7bc8ca47]
15
16Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
17---
18 meson.build | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/meson.build b/meson.build
22index e1e3b1d..3f45f0e 100644
23--- a/meson.build
24+++ b/meson.build
25@@ -173,7 +173,7 @@ endif
26
27 gir = find_program('g-ir-scanner', required : get_option('introspection'))
28 gnome = import('gnome')
29-build_gir = gir.found() and not meson.is_cross_build()
30+build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled())
31 gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' + \
32 'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \
33 'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
34--
352.17.1
36
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.0.bb
index 6a9995b0..0a3c35ff 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.0.bb
@@ -9,8 +9,7 @@ DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
9PNREAL = "gst-rtsp-server" 9PNREAL = "gst-rtsp-server"
10 10
11SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \ 11SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \
12 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ 12 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
13 file://gtk-doc-tweaks.patch \
14 " 13 "
15 14
16SRC_URI[md5sum] = "adc4460239ec2eccf58ad9752ce53bfd" 15SRC_URI[md5sum] = "adc4460239ec2eccf58ad9752ce53bfd"
@@ -18,17 +17,16 @@ SRC_URI[sha256sum] = "198e9eec1a3e32dc810d3fbf3a714850a22c6288d4a5c8e802c5ff984a
18 17
19S = "${WORKDIR}/${PNREAL}-${PV}" 18S = "${WORKDIR}/${PNREAL}-${PV}"
20 19
21inherit autotools pkgconfig upstream-version-is-even gobject-introspection gtk-doc 20inherit meson pkgconfig upstream-version-is-even gobject-introspection
22 21
23EXTRA_OECONF = "--disable-examples --disable-tests --disable-introspection " 22EXTRA_OEMESON += " \
23 -Dexamples=disabled \
24 -Dtests=disabled \
25"
26
27GIR_MESON_ENABLE_FLAG = "enabled"
28GIR_MESON_DISABLE_FLAG = "disabled"
24 29
25# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well 30# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well
26LIBV = "1.0" 31LIBV = "1.0"
27require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc 32require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
28
29delete_pkg_m4_file() {
30 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
31 rm "${S}/common/m4/pkg.m4" || true
32}
33
34do_configure[prefuncs] += " delete_pkg_m4_file"