summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-04-17 14:48:33 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-25 18:58:26 -0300
commitc7b44bfe13d81494f089b79d7c662cd7b941fb6e (patch)
treed4d233cd2eab298379472c0ab90572506329b45a
parentcaff565e628bf14fae1e5b861c950550de1357d5 (diff)
downloadmeta-freescale-c7b44bfe13d81494f089b79d7c662cd7b941fb6e.tar.gz
u-boot-qoriq: support big endian
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb b/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb
index 11964ba3..18013502 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb
@@ -53,8 +53,12 @@ python () {
53 d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-') 53 d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-')
54} 54}
55 55
56LE_UBOOT_FOR_ARMBE_TARGET ?= "0"
57ENDIANNESS_GCC = "${@bb.utils.contains("LE_UBOOT_FOR_ARMBE_TARGET", "1", "-mlittle-endian", "", d)}"
58ENDIANNESS_LD = "${@bb.utils.contains("LE_UBOOT_FOR_ARMBE_TARGET", "1", "-EL", "", d)}"
59
56WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 60WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
57EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1' 61EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${ENDIANNESS_GCC}" LD="${WRAP_TARGET_PREFIX}ld ${ENDIANNESS_LD}" V=1'
58EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"' 62EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
59 63
60inherit fsl-u-boot-localversion 64inherit fsl-u-boot-localversion