summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2019-05-23 16:39:28 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-12 14:45:07 -0300
commitb53d31959e078d4935fcaf8bbb90d95377e72e44 (patch)
tree50acfee58a6143c0d72634221312809131d0fc08
parentce4eb34fe6fb18da65b5916d35adff690c5c9f12 (diff)
downloadmeta-freescale-b53d31959e078d4935fcaf8bbb90d95377e72e44.tar.gz
weston: Add support for AGL and IVI
- For AGL, don't install weston.ini - For IVI, do install the IVI-shell version of weston.ini Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index 7649893b..10ce08ca 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -120,7 +120,14 @@ do_install_append() {
120 fi 120 fi
121 121
122 # install default weston.ini 122 # install default weston.ini
123 install -D -m 0644 ${WORKDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini 123 if [ -z "${@bb.utils.filter('BBFILE_COLLECTIONS', 'aglprofilegraphical', d)}" ]; then
124 if [ "${@bb.utils.filter('BBFILE_COLLECTIONS', 'ivi', d)}" ]; then
125 WESTON_INI_SRCDIR=${B}/ivi-shell
126 else
127 WESTON_INI_SRCDIR=${B}
128 fi
129 install -D -m 0644 ${WESTON_INI_SRCDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
130 fi
124} 131}
125 132
126PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ 133PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \