summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-12 22:42:22 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:15 -0300
commitb4b27bd8c3cb00971634099197d88dfdfdcedf26 (patch)
treec989aeee92b2ccd758db7d4c3c8f4407e6636f98
parentbe1037c79f97b9b9651045b6176cde91a67f6560 (diff)
downloadmeta-freescale-b4b27bd8c3cb00971634099197d88dfdfdcedf26.tar.gz
ipc: Optimize the ipc recipes directories
* move ipc-ust recipes to recipes-extended folder * move ipc-modules to recipes-kernel folder Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Acked-by: Daiane Angolini <daiane.angolini@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-extended/ipc-ust/ipc-ust_git.bb (renamed from recipes-bsp/ipc/ipc-ust_git.bb)4
-rw-r--r--recipes-extended/ipc-ust/ipc.inc (renamed from recipes-bsp/ipc/ipc.inc)1
-rw-r--r--recipes-kernel/ipc-modules/ipc-modules-multi_git.bb (renamed from recipes-kernel/ipc/ipc-modules-multi_git.bb)0
-rw-r--r--recipes-kernel/ipc-modules/ipc-modules-single_git.bb (renamed from recipes-kernel/ipc/ipc-modules-single_git.bb)0
-rw-r--r--recipes-kernel/ipc-modules/ipc-modules.inc (renamed from recipes-kernel/ipc/ipc-modules.inc)5
5 files changed, 4 insertions, 6 deletions
diff --git a/recipes-bsp/ipc/ipc-ust_git.bb b/recipes-extended/ipc-ust/ipc-ust_git.bb
index c6b3cfe6..5ba3411f 100644
--- a/recipes-bsp/ipc/ipc-ust_git.bb
+++ b/recipes-extended/ipc-ust/ipc-ust_git.bb
@@ -45,6 +45,6 @@ do_install () {
45 install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib 45 install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib
46} 46}
47 47
48FILES_${PN} += "/ipc/*" 48FILES_${PN} += "${base_libdir}/*.so /ipc/*"
49FILES_${PN}-dev = "${includedir}"
49FILES_${PN}-dbg += "/ipc/.debug" 50FILES_${PN}-dbg += "/ipc/.debug"
50
diff --git a/recipes-bsp/ipc/ipc.inc b/recipes-extended/ipc-ust/ipc.inc
index 547771ae..61b79768 100644
--- a/recipes-bsp/ipc/ipc.inc
+++ b/recipes-extended/ipc-ust/ipc.inc
@@ -4,4 +4,3 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;nobranch=1"
4SRCREV = "c9c92ac6a7a31c9d878096eb7d135c22a38f20ff" 4SRCREV = "c9c92ac6a7a31c9d878096eb7d135c22a38f20ff"
5 5
6COMPATIBLE_MACHINE = "(bsc9132qds|bsc9131rdb|b4860qds|b4420qds)" 6COMPATIBLE_MACHINE = "(bsc9132qds|bsc9131rdb|b4860qds|b4420qds)"
7
diff --git a/recipes-kernel/ipc/ipc-modules-multi_git.bb b/recipes-kernel/ipc-modules/ipc-modules-multi_git.bb
index e5dc1151..e5dc1151 100644
--- a/recipes-kernel/ipc/ipc-modules-multi_git.bb
+++ b/recipes-kernel/ipc-modules/ipc-modules-multi_git.bb
diff --git a/recipes-kernel/ipc/ipc-modules-single_git.bb b/recipes-kernel/ipc-modules/ipc-modules-single_git.bb
index 03817e0e..03817e0e 100644
--- a/recipes-kernel/ipc/ipc-modules-single_git.bb
+++ b/recipes-kernel/ipc-modules/ipc-modules-single_git.bb
diff --git a/recipes-kernel/ipc/ipc-modules.inc b/recipes-kernel/ipc-modules/ipc-modules.inc
index 79ba7ef1..a496ab6d 100644
--- a/recipes-kernel/ipc/ipc-modules.inc
+++ b/recipes-kernel/ipc-modules/ipc-modules.inc
@@ -3,9 +3,9 @@ DESCRIPTION = "DSP boot application and ipc test application"
3LICENSE = "BSD" 3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10" 4LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5 5
6require recipes-bsp/ipc/ipc.inc 6require recipes-extended/ipc-ust/ipc.inc
7 7
8inherit module qoriq_build_64bit_kernel 8inherit module qoriq_build_64bit_kernel
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
@@ -23,4 +23,3 @@ do_compile_prepend () {
23} 23}
24 24
25INHIBIT_PACKAGE_STRIP = "1" 25INHIBIT_PACKAGE_STRIP = "1"
26