summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@oss.nxp.com>2024-04-24 08:34:54 -0500
committerTom Hochstein <tom.hochstein@oss.nxp.com>2024-04-24 08:34:54 -0500
commitaa1e6f2be3e1b006d25850d2581031f78bc16327 (patch)
treec8394f98b0abfc8ae518340500129880492cd309
parentaeb8cdbecbd88ff4daa9ddc0ea74dd6f81b89f0b (diff)
downloadmeta-freescale-aa1e6f2be3e1b006d25850d2581031f78bc16327.tar.gz
alsa-lib: Update patch for IMX-XCVR.conf
Signed-off-by: Tom Hochstein <tom.hochstein@oss.nxp.com>
-rw-r--r--recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch74
1 files changed, 22 insertions, 52 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch b/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
index f801309e..1f558185 100644
--- a/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
+++ b/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
@@ -1,4 +1,4 @@
1From cfbe756d55a303803805d3e8e3d3cf3b97866964 Mon Sep 17 00:00:00 2001 1From 36aae65dc913e1ebe72366d7ae361897d465e88d Mon Sep 17 00:00:00 2001
2From: Viorel Suman <viorel.suman@nxp.com> 2From: Viorel Suman <viorel.suman@nxp.com>
3Date: Mon, 9 Mar 2020 14:25:46 +0200 3Date: Mon, 9 Mar 2020 14:25:46 +0200
4Subject: [PATCH] add conf for iMX XCVR sound card 4Subject: [PATCH] add conf for iMX XCVR sound card
@@ -8,18 +8,18 @@ Upstream-Status: Pending
8Signed-off-by: Viorel Suman <viorel.suman@nxp.com> 8Signed-off-by: Viorel Suman <viorel.suman@nxp.com>
9 9
10--- 10---
11 src/conf/cards/IMX-XCVR.conf | 69 ++++++++++++++++++++++++++++++++++++ 11 src/conf/cards/IMX-XCVR.conf | 39 ++++++++++++++++++++++++++++++++++++
12 src/conf/cards/Makefile.am | 3 +- 12 src/conf/cards/Makefile.am | 3 ++-
13 src/conf/cards/aliases.conf | 1 + 13 src/conf/cards/aliases.conf | 1 +
14 3 files changed, 72 insertions(+), 1 deletion(-) 14 3 files changed, 42 insertions(+), 1 deletion(-)
15 create mode 100755 src/conf/cards/IMX-XCVR.conf 15 create mode 100755 src/conf/cards/IMX-XCVR.conf
16 16
17diff --git a/src/conf/cards/IMX-XCVR.conf b/src/conf/cards/IMX-XCVR.conf 17diff --git a/src/conf/cards/IMX-XCVR.conf b/src/conf/cards/IMX-XCVR.conf
18new file mode 100755 18new file mode 100755
19index 0000000..ee323c7 19index 0000000..009000c
20--- /dev/null 20--- /dev/null
21+++ b/src/conf/cards/IMX-XCVR.conf 21+++ b/src/conf/cards/IMX-XCVR.conf
22@@ -0,0 +1,69 @@ 22@@ -0,0 +1,39 @@
23+# 23+#
24+# Configuration for the IMX-XCVR sound card using software IEC958 24+# Configuration for the IMX-XCVR sound card using software IEC958
25+# subframe conversion 25+# subframe conversion
@@ -27,21 +27,10 @@ index 0000000..ee323c7
27+IMX-XCVR.pcm.default { 27+IMX-XCVR.pcm.default {
28+ @args [ CARD ] 28+ @args [ CARD ]
29+ @args.CARD { type string } 29+ @args.CARD { type string }
30+ type asym 30+ type plug
31+ playback.pcm { 31+ slave.pcm {
32+ type linear 32+ @func concat
33+ slave.pcm { 33+ strings [ "iec958:" $CARD ]
34+ @func concat
35+ strings [ "iec958:" $CARD ]
36+ }
37+ slave.format S24_LE
38+ }
39+ capture.pcm {
40+ type plug
41+ slave.pcm {
42+ @func concat
43+ strings [ "iec958:" $CARD ]
44+ }
45+ } 34+ }
46+} 35+}
47+ 36+
@@ -54,40 +43,21 @@ index 0000000..ee323c7
54+ @args.AES1 { type integer } 43+ @args.AES1 { type integer }
55+ @args.AES2 { type integer } 44+ @args.AES2 { type integer }
56+ @args.AES3 { type integer } 45+ @args.AES3 { type integer }
57+ type asym 46+ type iec958
58+ playback.pcm { 47+ slave {
59+ type hooks 48+ format IEC958_SUBFRAME_LE
60+ slave.pcm { 49+ pcm {
61+ type hw 50+ type plug
62+ card $CARD 51+ slave.pcm {
63+ } 52+ type hw
64+ hooks.0 { 53+ card $CARD
65+ type ctl_elems
66+ hook_args [
67+ {
68+ interface PCM
69+ name "IEC958 Playback Default"
70+ preserve true
71+ optional true
72+ value [ $AES0 $AES1 $AES2 $AES3 ]
73+ }
74+ ]
75+ }
76+ }
77+ capture.pcm {
78+ type iec958
79+ slave {
80+ format IEC958_SUBFRAME_LE
81+ pcm {
82+ type plug
83+ slave.pcm {
84+ type hw
85+ card $CARD
86+ }
87+ } 54+ }
88+ } 55+ }
89+ status [ $AES0 $AES1 $AES2 $AES3 ]
90+ } 56+ }
57+ status [ $AES0 $AES1 $AES2 $AES3 ]
58+ preamble.z 0x0
59+ preamble.x 0x1
60+ preamble.y 0x3
91+} 61+}
92diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am 62diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am
93index 34fa5a3..70b9bab 100644 63index 34fa5a3..70b9bab 100644