summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-07-26 13:13:01 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-12-13 07:26:04 -0200
commita77be07199b5ead5c9a77f5876c10d8638921806 (patch)
tree5069b0220750a2f944cc267635485852ce46ffe0
parent57f7fc23354953a96cc3996518f6dfe5a4bfb132 (diff)
downloadmeta-freescale-a77be07199b5ead5c9a77f5876c10d8638921806.tar.gz
imx-atf: Add new package ARM Trusted Firmware
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch29
-rw-r--r--recipes-bsp/imx-atf/imx-atf_1.5.0.bb47
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch b/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch
new file mode 100644
index 00000000..be747789
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch
@@ -0,0 +1,29 @@
1From 4123893a8a4d93362a0a36f72134f75436fee457 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Thu, 18 Oct 2018 18:03:46 -0500
4Subject: [PATCH] Allow BUILD_STRING to be set in .revision file.
5
6Upstream-Status: Pending
7
8Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
9---
10 Makefile | 3 +++
11 1 file changed, 3 insertions(+)
12
13diff --git a/Makefile b/Makefile
14index 57c4a90..ec49397 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -97,6 +97,9 @@ endif
18
19 # Default build string (git branch and commit)
20 ifeq (${BUILD_STRING},)
21+ BUILD_STRING := $(shell cat .revision 2> /dev/null)
22+endif
23+ifeq (${BUILD_STRING},)
24 BUILD_STRING := $(shell git describe --long --always --dirty --tags 2> /dev/null)
25 endif
26 VERSION_STRING := v${VERSION_MAJOR}.${VERSION_MINOR}(${BUILD_TYPE}):${BUILD_STRING}
27--
282.7.4
29
diff --git a/recipes-bsp/imx-atf/imx-atf_1.5.0.bb b/recipes-bsp/imx-atf/imx-atf_1.5.0.bb
new file mode 100644
index 00000000..9d402dba
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf_1.5.0.bb
@@ -0,0 +1,47 @@
1# Copyright 2017-2018 NXP
2
3DESCRIPTION = "i.MX ARM Trusted Firmware"
4SECTION = "BSP"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
7
8PV = "1.5.0+git${SRCPV}"
9
10SRCBRANCH = "imx_4.9.123_imx8mm_ga"
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12 file://0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch \
13"
14SRCREV = "af3554fc6ea8c17710ffd37a14a25834fad19271"
15
16S = "${WORKDIR}/git"
17
18inherit deploy
19
20BOOT_TOOLS = "imx-boot-tools"
21
22PLATFORM ?= "INVALID"
23PLATFORM_mx8qm = "imx8qm"
24PLATFORM_mx8qxp = "imx8qxp"
25PLATFORM_mx8mq = "imx8mq"
26PLATFORM_mx8mm = "imx8mm"
27
28EXTRA_OEMAKE += " \
29 CROSS_COMPILE="${TARGET_PREFIX}" \
30 PLAT=${PLATFORM} \
31"
32
33do_compile() {
34 # Clear LDFLAGS to avoid the option -Wl recognize issue
35 unset LDFLAGS
36 oe_runmake bl31
37}
38
39do_install[noexec] = "1"
40
41do_deploy() {
42 install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin
43}
44addtask deploy after do_compile
45
46PACKAGE_ARCH = "${MACHINE_SOCARCH}"
47COMPATIBLE_MACHINE = "(mx8)"