summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-08-14 11:17:16 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-04 18:33:08 -0300
commit862bafc6e4faf75eceafbee4c1f4be4df5b06e49 (patch)
tree7e9c5e4c7c7dc9700ef0d1a7b8a79527b4802bca
parentc13fb0aa3cc8bb9d3aa8f6649e79c8443256bf23 (diff)
downloadmeta-freescale-862bafc6e4faf75eceafbee4c1f4be4df5b06e49.tar.gz
ceetm: fix the building warning
*fix the below warning |#warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp] *add 0001-Makefile-update-CFLAGS.patch to avoid build Errors. *remove do_compile_prepend *Obey LDFLAGS and CFLAGS in Makefile Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
-rw-r--r--recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch31
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb11
2 files changed, 37 insertions, 5 deletions
diff --git a/recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch b/recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch
new file mode 100644
index 00000000..13697886
--- /dev/null
+++ b/recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch
@@ -0,0 +1,31 @@
1From fb1fe93a2bab083652a65804be5ddd37a7e86a9f Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 14 Aug 2019 04:05:14 +0200
4Subject: [PATCH] Makefile: update CFLAGS
5
6*fix the below error:
7|error: json_print.h: No such file or directory
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
12---
13 Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/Makefile b/Makefile
17index f89700c..49243d8 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -8,7 +8,7 @@ LDFLAGS += -Wl,-export-dynamic
21 # if you are not using flex-builder. Download the iproute2 sources for the
22 # desired version and point to those instead.
23 ifneq ($(IPROUTE2_DIR),)
24-CFLAGS += -I$(IPROUTE2_DIR) -I$(IPROUTE2_DIR)/include
25+CFLAGS += -I$(IPROUTE2_DIR) -I$(IPROUTE2_DIR)/include -I$(IPROUTE2_DIR)/usr/include/ -I$(IPROUTE2_DIR)/usr/include/include
26 endif
27
28 MODDESTDIR := $(DESTDIR)/usr/lib/tc
29--
302.7.4
31
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
index 8613e507..68fb67e0 100644
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -4,16 +4,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bac620b9883d38a84dfb73ca7122d915"
4 4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1" 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1"
6SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b" 6SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b"
7 7SRC_URI_append = " file://0001-Makefile-update-CFLAGS.patch \
8"
8DEPENDS = "iproute2" 9DEPENDS = "iproute2"
9 10
10S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
11 12
12EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" IPROUTE2_DIR="{STAGING_DIR_TARGET}"' 13export IPROUTE2_DIR="${STAGING_DIR_TARGET}"
14WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
15export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
13 16
14do_compile_prepend () { 17LDFLAGS += "${TOOLCHAIN_OPTIONS}"
15 cp ${RECIPE_SYSROOT}/usr/include/include/json_print.h ${RECIPE_SYSROOT}/usr/include
16}
17 18
18do_install(){ 19do_install(){
19 mkdir -p ${D}/${libdir}/tc 20 mkdir -p ${D}/${libdir}/tc